Good day all

I have completed my F450 copter with a pixhawk 2.4.8 a month or so ago.

Setup :


pixhawk 2.4.8

APM copter 3.5.5

R_XSR receiver

BL-Heli 32 ESC ( 40 A)

All went well and I completed all the tests : i.e. waypoint flights, RTL, failsafes...

all of it.

Started putting on a camera gimbal 2 nights ago and I was having problems.

Today, when I wanted to fly my copter the one motor did not want to spin.

I suspected a problem with me changing the PWM channel configs to access the gimbal.

I then reversed any settings made for the gimbal ( by referting back to the backups of the

parameter-list which I regularly make. I could then fly again but all of a sudden I had

a massive vibration issue. After all of my efforts failed I reverted to re-flashing my pixhawk

( now with the latest 3.5.7 ) and recalibrating everything. 

I am now constantly getting a : pre-arm : check FS_THR_VALUE and in an effort to solve this , I disabled all arming checks ( just for the moment ) . I then get a GREEN LED which means the 

pixhawk is readt but when I push my stick down and right, nothing happens. I also noticed during my

recalibraion, one of the last windows was a "checklist" of everything that checked out and the

last one was " are you able to arm the pixhawk with your RC " and it was red. 

I cannor recall that, during the initial building of my drone, that there is a place to actually tell pixhawk to arm when you push your stick down and right.

Can someone assist please !!! 

Many thanks !!

Views: 210

Reply to This

Replies to This Discussion

Good evening

Since I made this post, I have done the following:

Reset all parameters to default. Re-calibbrated my copter.

I redefined another model on my RC ( incase it is something on my RC config )

I also did the following test:

I connected my 433MHz radio to my laptop and enabled my joystick so that I can fly my copter from the ground

station (MP). It armed and flew wonderfully. Even the vibration that I picked up all of a sudden is gone ( I suspect the ESC;s required a re-call )

But ... I cannot arm from my RC......

Oh dear .....

Good evening all

I have solved the problem and wish to add a description here so that anyone else can benefit.

Turned out that the RC needed calibration. Yes, I DID calibrate it during the the WIZARD cycle, but for one reason

or another, that was not sufficient. Please note : the display on RC calibrate (under initial setup on MP )did show normal activity i.e. bars changing

state as I moved the sticks. This does not imply correct calibration.

Here is what I did : 

Before I did anything I did a test that I did not do before hand. And that is the lost-copter-alarm :

right gimbal down and right. And the fact that nothing happened, confirmed that there is something wrong with the RC

setup because an ARM can still be blocked by a pre-arm failsafe but a lost-copter-alarm should not be blocked.

Then I did a re-calibrate under Initial setup in MP NOT using the wizard. Then it armed and the lost-copter alarm also

worked again.

Then something else happened : now my motors would not turn with the RC or with joystick-via-MP.

But a simple re-calibrate of ESC under initial setup NOT the wizard, fixed that.

I now have my drone in perfect flying condition again. I shall just go through all the flight tests again to check 

all that functionality as well.

Not sure why an RC-calibrate worked for the hexa under the WIZARD but was not succesfull for the quad

See you all on the next one !!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service