Copter not arming

Good day all

I have completed my F450 copter with a pixhawk 2.4.8 a month or so ago.

Setup :

F450

pixhawk 2.4.8

APM copter 3.5.5

R_XSR receiver

BL-Heli 32 ESC ( 40 A)

All went well and I completed all the tests : i.e. waypoint flights, RTL, failsafes...

all of it.

Started putting on a camera gimbal 2 nights ago and I was having problems.

Today, when I wanted to fly my copter the one motor did not want to spin.

I suspected a problem with me changing the PWM channel configs to access the gimbal.

I then reversed any settings made for the gimbal ( by referting back to the backups of the

parameter-list which I regularly make. I could then fly again but all of a sudden I had

a massive vibration issue. After all of my efforts failed I reverted to re-flashing my pixhawk

( now with the latest 3.5.7 ) and recalibrating everything. 

I am now constantly getting a : pre-arm : check FS_THR_VALUE and in an effort to solve this , I disabled all arming checks ( just for the moment ) . I then get a GREEN LED which means the 

pixhawk is readt but when I push my stick down and right, nothing happens. I also noticed during my

recalibraion, one of the last windows was a "checklist" of everything that checked out and the

last one was " are you able to arm the pixhawk with your RC " and it was red. 

I cannor recall that, during the initial building of my drone, that there is a place to actually tell pixhawk to arm when you push your stick down and right.

Can someone assist please !!! 

Many thanks !!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Good evening all

    I have solved the problem and wish to add a description here so that anyone else can benefit.

    Turned out that the RC needed calibration. Yes, I DID calibrate it during the the WIZARD cycle, but for one reason

    or another, that was not sufficient. Please note : the display on RC calibrate (under initial setup on MP )did show normal activity i.e. bars changing

    state as I moved the sticks. This does not imply correct calibration.

    Here is what I did : 

    Before I did anything I did a test that I did not do before hand. And that is the lost-copter-alarm :

    right gimbal down and right. And the fact that nothing happened, confirmed that there is something wrong with the RC

    setup because an ARM can still be blocked by a pre-arm failsafe but a lost-copter-alarm should not be blocked.

    Then I did a re-calibrate under Initial setup in MP NOT using the wizard. Then it armed and the lost-copter alarm also

    worked again.

    Then something else happened : now my motors would not turn with the RC or with joystick-via-MP.

    But a simple re-calibrate of ESC under initial setup NOT the wizard, fixed that.

    I now have my drone in perfect flying condition again. I shall just go through all the flight tests again to check 

    all that functionality as well.

    Not sure why an RC-calibrate worked for the hexa under the WIZARD but was not succesfull for the quad

    See you all on the next one !!

  • Good evening

    Since I made this post, I have done the following:

    Reset all parameters to default. Re-calibbrated my copter.

    I redefined another model on my RC ( incase it is something on my RC config )

    I also did the following test:

    I connected my 433MHz radio to my laptop and enabled my joystick so that I can fly my copter from the ground

    station (MP). It armed and flew wonderfully. Even the vibration that I picked up all of a sudden is gone ( I suspect the ESC;s required a re-call )

    But ... I cannot arm from my RC......

    Oh dear .....

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
2 hours ago
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
2 hours ago
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
2 hours ago
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
More…