Copter tried to kill me, Grinding noise then stuck at full throttle.

So heres the scoop. I had a well flying quadcopter using an APM 2.6. I decided to move to pixhawk. Bought a brand new unit from 3dr. Wired everything up and installed 3.2 Took it out to fly today and wasn't able to get it off the ground. The throttle and motors seemed to be acting weird and it sounded almost like a grinding sound. Keep in mind these motors flew through two batteries just the other day on my APM 15min flights each without a hiccup. The only thing thats changed since then is the flight controller. I brought it home and flipped the props and went to work trying to debug. I did the motor test in mission planner and ran each motor up to 15% throttle. Everything seemed fine, no weird grinding. So I got my camera out and started recording while I armed and tried the throttle. Again I was getting the grinding noise, then I noticed that above 50% throttle it seemed like no more actual throttle was being applied but the grinding noise got louder. I blipped the throttle a few times and sure enough it would seem thrust was coming up to the 50% point and then it was just making a louder grinding noise but not giving anymore thrust beyond that. SUDDENLY all the motors went to full power. No grinding noise anymore. I closed the throttle but nothing happened it was stuck wide open. I tried to disarm but it wasn't responding, so i took cover behind the bed as you can see in the video. The whole time I am trying to disarm. Eventually unsure of what my best move was I decided to turn off my transmitter. A moment later the motors returned to idle and I was able to disarm through my laptop (which I might have been able to do all along but in the rush I didnt think of it). 

To put it lightly, what the hell is going on. 

Video here, you can hear the grinding initially (warning loud)

Photo of the carnage below. 

Views: 2014


Reply to This

Replies to This Discussion

The provided log displays motors properly follow RCIN.C3  - it's not pixhawk, but maybe your radio or RX that tried to kill you.

I suggest you see Stephen King's movie "Trucks" for related clues :)

To seewhat I do, plot RCIN.3 , and RCOUT.Chan1...4

Ya i'm kinda ignoring the throttle issue for now. Its possible that was user error as the logs seem to suggest there was input. That doesn't explain the grinding sound though. 

Ok, the motor sound indicates a wrong timing of the ESCs. This would explain why its fine with props dismounted and only appears while the motors are under load.
Wrong timing can also be the case for the erratic throttle behavior. Could it be that you intended to recalibrate your ESCs after upgrading to the Pixhawk and thereby you accidentially entered into the ESC programming mode and changed the motor timing?

I doubt it. To my understanding Afros don't need throttle calibration so I've never calibrated them. I wired this up and took it right out to fly, so i'd be surprised if I somehow accidentally entered calibration mode, especially on a pixhawk where you need to do some special things with the switch to calibrate escs. 

It certainly sounds like a Sync issue to me.  EG:

You absolutely should have signal and ground wires attached to your APM/Pixhawk..  Leave any BEC power disabled until you've sorted the issue.

There's a known issue with Afro ESCs. Please see this thread for solutions. 

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service