A couple of days my quad crashed, because I'm kind of new to Arducopter I would like you to review my reasoning (log file is attached to this post).

The flight & crash

After having flown for some minutes on a mountain hill in Loiter (+- 10th quad flight), I decided to increase the height of my F450, 2212, 9443 props, to record a nice shot with my attached action cam. After this shot I lowered the height of the quad, and when it reached about 10M above the hill's surface I gave full throttle. Unfortunately, the Quad didn't stop declining (but remained 'horizontal') but crashed and rolled down for 10 meters or so.

The log analysis

1. moment of impact; from the Yaw and Roll parameter I found out that the moment of impact is 13895.

2. the power send to the motors, from CH1-4 I found out that motor 3 is running at full throttle (and that it's waveform is much more 'digital' compared to the waveforms of the other ESC channels?).

- because the quad remained flat (didn't flip), the prop was still on the motor.

- because the quad remained flat and CH3 was on full throttle I ASSUME that the other motors were not able to run at a higher throttle (stability issues)

SO, I expect that my COG is not in the center of the quad frame (due to the off center placed action cam and the GPS) because of the fact that CH3 has to work harder (but not everywhere in flight! strange?). Furthermore I expect that my quad is a bit underpowered because CH3 is not able to keep the quad in the horizontal plane when other motors would be spinning (only in this situation!). Do you AGREE?

3. the ANGBST parameter is strong>-1000 (MINUS!) during the decline, what is the reason for this?

Furhtermore, I've done this shot 10 more times, but the quad didn't crash, what could be the reason for this (same hardware config)? (Wind?) Although I made one hard landing during an earlier flight when I came from 50 meters high (I think that this cause was the same as this crash cause).

Solution:

Attach bigger props to my quad, to increase the thrust from 650 gram per motor to 1050 gram per motor (as the quad AOW is 1.7 kilo!

Thanks a lot!

Views: 279

Attachments:

Reply to This

Replies to This Discussion

Vortex ring state maybe? I am seeing some i2c errors, reroute your mag cable and there is a problem with current sensing but neighter should be the reason. Could still be VRS. Was there any wind at all?

Thank you for your comment! After doing some research this seems to be the cause of the crash (the quad was 'wobbling' during it's descent and didn't respond on it's throttle).

What could be the reason that one of the motors (CH3) was on full throttle?

Micha said:

Vortex ring state maybe? I am seeing some i2c errors, reroute your mag cable and there is a problem with current sensing but neighter should be the reason. Could still be VRS. Was there any wind at all?

While it is in VRS state a bit of forward stick should clear the vortex and the wobbling is indeed a sign. Without seeing your rig it is difficult to comment on CH3 as it is quite possible that your cog is the reason. If not excessive that should not be a problem. Remember that it is not uncommon to see 1 motor being at full throttle while the 3 others are near to maintain attitude. Cog can be a reason but even a slight breeze at a certain direction can have this effect while on full throttle. Your quad stayed more or less level during the VRS so i see no problem there.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service