hi,

does someone get missionplanner running on armhf?

exact:

  • cubieboard 2
  • debian linux armhf version
  • mono -- thats my current problem
  • missionplanner

i do not find a working mono runtime for armhf.

/g

wolke

Views: 887

Reply to This

Replies to This Discussion

solved:)),

found APM planner based on qgroundcontrol and QT. i am sure that this can compiled and running on armhf based boards.

great:)).

if i get it running i will post my experience here.

/g

wolke

jep,

success. APM planner runs now on my cubieboard. don't know why, but deployment with qmake on armhf based linux systems is a pain. there was many problems with install directory(files, data, qml). in project code i found so many hard coded file-paths. first i have change them all also hard coded to get fast success . but maybe i create a ticket on github. also on armhf is a gcc bug in gcc4.6 and gcc4.7 which caused an assembler index out of range error in MAVLinkInspector widget. at first i removed this widget. maybe on  a groundstation not so important, because this is more a development tool if you try to find MAVLink message problems.

at all it will run ok on my cubieboard. HUD display eat a lot of cpu. think this can improved.

but working on armhf based boards with the amount of gpio's is the next step to create an nice and cheap 3dr radio based hand-held groundstation with joysticks like this http://www.hobbyking.com/hobbyking/store/__39505__transmitter_gimba..., a small touch display, all switches  many led s and a small speaker inside.

wintertime is diy project time.

Hi there,

I am also trying to run AP2 on a PCDUINO (i have installed openglES driver and it works), but i stuck with libopenscenegraph-dev that doesn't exist for a 12.04 for armhf. what kind of distribution of linux do you have ?

hello Im trying to install apm planner on raspberry pi. Could you tell me how did you do it?

I tried mono runtime for mission planner but it just doesnt works, and also i tried to type sudo dpkg -i apm_planner*.deb 

with the apm_planner debian i386 version and just doesnt works

here is a video and a link to do it on rasp : https://www.youtube.com/watch?v=1Q1M9mO1DxY

And just to share this, I have managed to run Apm planner on my pcduino V2 (allwinner 1Ghz). Here is how i did it:

- I run a debian for arm allwinner (cubiezz) on the pcduino because OSG is available for armhf on dedian weezy or sid

- you have to install sb2, qemu and all tools you need to cross-compil the soft on a computer. I have tried to compil it directly on the target, but it's to slow, and GCC have some segmentation fault that seems to come from hardware problem (i think the memory on these board is not really good).

- follow the intructions to compil the apm planner on https://github.com/diydrones/apm_planner with sb2.

- then just copy the content of the release directory on your target and run it. Of course, you must have the same libraries on your computer and on your arm target.

I join a picture to show that it's running on pcduino. i tried to connect the telemetry, and it works.

Attachments:

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service