Hello,

I'm attempting to solve an issue with IMU readings from a new APM2 being used on a multirotor (hex).

  • Artificial horizon 'jumping', constantly changing orientation, rapid random steps-not smooth
  • Heading is 'jumping' in the same manor
  • Unconfirmed: but xBee seems to have bricked as well, was unable to connect via xBee after first reboot and a number of subsequent reboots, have been connecting USB since. 

I'm running APM firmware 2.5.3 Hexa and interacting through APM Planner 1.1.58.

The airframe is the 3DR Hexa set up per instructions with the power distribution board, sonar, and xBee.

Climate: outside, warm, and dry.

The platform had a couple test flights the day prior with no issues, now the artificial horizon is erratic, upon first connect/flight of the day.

I have not attempted a flight in this condition.

Things I've tried with no effect (more or less in order, restarting APM between logical steps):

  • Connecting through USB to eliminate battery and ECSs and xBee
  • Disconnecting xBee & sonar/disabled sonar
  • Changing location, outside/inside
  • Disconnecting radio gear & power PCB
  • Calibrating magnetometer
  • Leveling IMU (setting IMU offsets in 'setup' menu in Planner)
  • Reinstalling firmware

After all these attempts I gathered this info:

  • IMU data from Planner's terminal interface
    • These readings are erratic
  • Magnotometer data from Planner's terminal interface
    • These readings seem normal
  • Short log file through Planner
    • Platform sitting still inside producing erratic readings
I hope my description is concise enough to get this guy working again soon.
Thanks in advanced!
Nick

Included:

  • log file: 2012-03-28 11-13-00.tlog
  • text file of magnetometer  data: mag_data.txt
  • text file of imu data: gyro_readings.txt

Views: 552

Attachments:

Reply to This

Replies to This Discussion

I have an identical problem. Did you ever get this fixed?

I managed to fix this by doing a factory reset from the command line.

>setup

>reset

I found this problem reared its head again when I tried to configure the sonar/ofs from the mission planner.  If I set the sonar up from the command line, the gyro behaved itself.  At present (as I understand it) the OFS is not supported on the APM2. I've wire it up as per the manual but can't get it to enable. Waiting for the next major release :-(

Hey thanks,

I tried the factory reset as well with success, thanks so much.

I contacted DIY drones after my post sat unanswered for a while and they never truly got back to me until just after I tried your advice.

-Nick

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service