Received my purple yesterday, just in time for Xmas ;)   Connected it all to my quad and it all seems to work (radio input, sensors, xbee).

What I can't get to work right now is the arming of the ESCs. I can arm the APM and verified outputs 1-4 with a servo (raw/radio view shows 1-4 output going up when adding throttle). But because the ESCs do not arm the motors do not spin up.

When powering the system up the ESC play the short melody. This is normally followed by a beep for each cell and then a long beep. However this part does not happen right now. Once in a blue moon, ESC number 4 arms and spins.

I calibrated all 4 ESC manually and they arm properly when connected directly to the receiver. Also tried to calibrate them with a trim offset to make sure they take a higher signal as 0 throttle. The calibration through the APM does not seem to work. The light do the dance on the initial power-up. But the ESCs do not seem to get the high throttle signal on the second power-up.

Could it be that my ESCs do not like the signal from the APM? It worked with APM1, KK and multiwii...

For now I'm out of ideas. Any input is appreciated.

Thanks, Andreas

Views: 8116

Reply to This

Replies to This Discussion

So, I received my purple board, hooked it up, loaded the latest coad with the mission planner, everything checks out, board arms but no response from motors. I also tried the work around it did not work. Any help much Appreciated.



Toby, the only work around I'm aware of is the patch that Chris posted on page 3 of this thread.  Unfortunately it didn't work for me.  The thing I currently know of is to get different esc's or have a separate battery or laptop with you all the time to power up the board first. 

Just out of curiosity, what radio/receiver are you all using?

Did anyone else figure out a workaround?  

Just got my APM2 in. Ive had the same problem all day. I found a solution that worked for me. I reversed my yaw on my TX and then was able to arm the APM by moving down/left for 4sec. Then changed it back after to fly correctly. For some reason it will not work without being reversed. I even tried doing theorient side but never had any luck. I did find that I had to be in "unreversed" to disarm by moving down/left again. Moving to the right does nothing.

I found that not all plush 40's have the same hardware design. Some can be custom modified with a older jtag connection. What is important is that all of them should of the same hardware generation without any OEM firmware mods. Standards are important.

Hi Vishal,

thanks for the reply. I have a Spektrum DX8 tx and AR7010 rx. I'm using the PDB fron diydrones store. I manualy calibrated each ESC and each worked fine when seperately hooked up to the rx. All ESCs armed fine with my APM1 with the exact same setup.  It's only when I switch to the purple board. the motors dont wanna work for some reason.

The only other work around i've found that's working for people  is powering up the board first via usb, let it boot then plug in the lipo. Did not work for me though.



That is interesting for sure.  When I got my esc's, a friend of mine and I had ordered them together and they came in as one order and are all the same version.  We both also have the same motors and a lot of other similarities between our copters.  The only difference in electronics is that I use a Spektrum DX7 tx and AR7000 rx.  He uses the Turnigy 9x and Turnigy receiver.  My 2.0 board won't arm my esc's on my setup.  But if we plug in the 2.0 board on my friend's copter, it arms the esc's just fine. 

We've double, triple, etc checked all our settings and done the esc calibration countless times.   It still comes back to the only difference being our radio system.  A while back I had ordered a Turnigy 9X for myslef but haven't yet used it.  Sometime, I'll try hooking it up in place of my Spektrum radio to see if that changes things at all. 

I wonder if all the others in this thread are also using Spektrum radios?

What radio system are you using ?

I'm also getting this issue on my APM2 with Plush 30 amp ESCs.  I've found that the only way to ensure that all ESCs are initialized is to let the APM2 boot and then hit the reset buttons a few times until I get the battery-cell beeps out of my ESCs.  They work properly after that.

This is on Arducopter 2.5.

Nevermind about the radio, it has no effect on this issue.  This weekend I built my a new hexacopter. For this I had ordered new esc's- Exceed RC 30A and also used my Turnigy 9x radio.  Even with all new electronics, the problem is still there with the APM 2 board. 

So, it seems that the problem is still the board.  Has anyone else figured out what causes this?  Currently I have to plug it into usb first in order to get the esc's to arm properly. But it shouldn't have to be this way since it works fine with the old board. 

Since it will work fine if I power the input and output sides separately, I'm thinking of just getting a separate little battery for the input side.  I believe we can't go over 5volts for that.  I'm thinking a 1S 400mah Lipo ought to work.  Only thing is I don't know the draw, so I have no idea how long this would last. I'd rather not find out by trial-and-error :-)

Does anyone from the development team know of an ideal lipo battery to power the input side separately?

A 400 mah battery will last you way beyond your primary battery.  You can always just power your electronics up with the full battery and time how long it takes them to die (not flying obviously).

I'd rather a fix for this issue be figured out.  I'd rather not have to fly an extra battery.  I've got three different APM2s exhibiting this behavior.  It is unquestionably an issue with the APM2, either with the board or with the firmware.

Well, I got an inexpensive 600mah 1s lipo that is intended for the Novus CP copter and use it to power the inputs.  I had it plugged in and powering the board for over 16 minutes.  This also powered the telemetry.  When I charged the battery back to full it only needed 170mah.  So this battery will work very well. It's really small and lightweight.

For anyone who has the esc arming issue and doesn't always want to carry a laptop to "jump start" the apm2, I would highly recommend going this route until a fix is found.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service