Hi all, 

Firstly I've made a lot of posts over the last few days on varying issues, so I'm sorry if I'm 'spamming' up the forum in any way, just having a few issues getting off the ground and looking to draw on this excellent community for advice. 

My issue is with ESC calibration. I have Mystery 30A ESC's, and I complete auto calibration successfully (two beeps with throttle up, put throttle down a further two confirmation beeps). On applying throttle all 4 motors spin up simultaneously, and as far as I can tell at the same speed. 

When I disconnect the battery and try again later, the following happens. The ESC's arm after 20-30 seconds with two confirmation beeps. This is all apart from motor 4 which does not appear to arm at all. When applying throttle three of the motors spin up, no response at all from motor #4. If I go through auto calibration again motor #4 will calibration successfully and once more for the duration that the LiPo is connected they will work in unison. Disconnection / reconnection recreates the problem. 

I've switched the motors around and it seems to always be output pin #4 not arming, independent of the ESC's or motors attached to it. 

Any ideas? Or am I forever going to have to complete ESC calibration every time I turn it on? 


Views: 4614

Reply to This

Replies to This Discussion

Doing further researched it appeared that this describes the problem I'm having fairly well, however I don't have any spare ESC's to plug in. Also this is happening on APM1 not 2. 

Any ideas? (Link http://www.diydrones.com/profiles/blogs/apm2-esc-startup-problem-an...)

if you are using 4 escs you only let 1 power the board so you cut the 5v wire on the other 3. have you done that ?

what happens when you use the motors test ?

Originally I had only 1 with the 5v (red wire in the brown / orange / red combo) connected and the three others disconnected. Then as I was going through the manual ESC calibration process it was a pain in the backside as I didn't have a separate power source for my RX so I connected them all back up. 

It's worth noting however that I'm using the 3D Robotics kit and their power distribution board (PDB). I'm unsure if this makes a difference. All ESC's are plugged into the PDB and then powering the actual "APM1" board is 5v running out of the PDB. 

At this point all ESC's have all 3 wires connected to the PDB, is this correct?

Edit: I'm fairly sure that because the 3d robotics PDB has only motor 1's 5v out going into the APM1, and the other 3 connections are left unsoldered it's effectively the same thing as what you're asking regardless of what wiring the actual ESC's have. 

Link - Picture of wiring, sorry for the rotation. http://imgur.com/kWxbY

if your using a PDB then your fine all 3 wires connect to the pbd then 4 signal leads and 1 power lead (1 gnd and 1 5V) goes into the APM.

edit: yeah looks alright in the picture

have you configured your radio in the APM ? try a factory reset

I've configured the radio in APM and also tried loading firmware fresh and going through the calibration process again. 

It may be worth mentioning that I do not need to hold the yaw to the right to arm the ESC's, it does it automatically on boot. I have tried holding yaw to the right / left (in case of reverse) and it doesn't make a difference to the motor. 

Also, the small switch on the right hand side of the oilpan which can be seen in the above photo, can I confirm this is meant to be slid towards the output pins during calibration, and away from the output pins (what is referred to as the fly position) when trying to fly normally?


Also for what it's worth I'm trying to do the motors command via CLI. I go into setup, type motors and it comes up with 'Now connect the lipo and follow the instructions.... etc etc. Any key to exit' but doesn't actually activate or do anything with the motors. 

I press any key to be sure it doesn't go onto the next step and it simply returns to the CLI prompt. 

Sorry to keep bumping but I'm adding information for diagnostics as I come across it. 

I'm once more trying a factory reset and running through CLI setup. 

I got to motors, as is usually happening for me, nothing happened so I figured I'd do an automatic ESC configuration again. After the auto configuration all 4 motors were working and responding to throttle inputs. 

With throttle low I plugged in the USB to try and connect via terminal to run the motors test. Upon plugging in the USB motor 1 went to high without any throttle command. I unplugged the USB and motor 1 went back to stationary, however this time when increasing the throttle motor #4 as usual would not work. So this has happened by only plugging in and removing the USB cable, the lipo was powering the APM the entire time. 

I would be starting from scratch at this point plug an ESC directly into your futaba receiver channel 3 and manually calibrate it then unplug and plug in again and see if it's happy. cut out the APM if that works then you a tleast know your ESC is working

Thanks again so much for your help. 

I pulled out the ESC from the troubled arm and calibrated it manually. It had no problems acknowledging high / low, and was responsive to throttle response. 

I then plugged the ESC control back into the PDB and powered up the quad with the LiPo in fly mode. Once more the ESC's beeped but once more that particular motor did not respond to throttle commands while all 3 others did. 

I'm also not sure if it's relevant but even with all three motors responding to throttle controls the green light isn't solid - it's still flashing. 

Went through and performed manual calibration on all the ESC's. Once more motor #4 would not initialise while the others armed. If I flip the 4 pin ESC connector seen in the above picture (so outputs 1-2-3-4 becoming 4-3-2-1) then straight away motor 4 initialises and responds to throttle, however motor #1 does not, in other words it's the output 4 pin that is causing problems, not the ESC, power or motor. 

Saying that - it doesn't make sense that a solder joint or something with pin 4 is the issue (physical damage) as it responds during the auto calibration to control the motor (and all others), just not afterwoulds. 


seem to have run out of replies ??

do you have access to a CRO oscilloscope ?

No sorry don't have access to an CRO. 

Good news and bad news 

Good news - I solved the issue 

Bad news - I have to delete my account out of embarassment

Protip - Do not load up the ArduCopter firmware (multiple times). Especially when you have a Quad. 

I'm so sorry I took up people's time with such a dumb problem. 

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service