Im using the stock 3dr 20 amp escs on my arducopter. I programmed 3 escs manually because I coulden't figure out the automatic programming. The last esc won't program. It always turns on, gives the start up beeps, the lipo beeps, and every few seconds it gives a single beep.


Any idea what the problem is?



Views: 284

Reply to This

Replies to This Discussion

I had similar last week with my new setup. It turned out that I had a dodgy ESC. It worked fine on its own, but didnt work when I had all 4 plugged in which added to the confusion.

I purchased another EXC and it solved the issue.

Do you also have a programming leaflet with the ESC as it usually tells you what the beeps mean ?

I did not get a programming leaflet with my arducopter kit with the stock 3dr 20 amp esc's. do you know where I can find a leaflet? My esc's suddenly started beeping rapidly after the 3 beep power up. I had been flying for a month until this happened. They beep rapidly even with no receiver powered on, so it can't be a transmitter calibration issue.

I'm not sure what that means. Contact 3DR tech support. If you can't get an answer I'll look for my packet to scan in.

Ok. It wasn't a xmtr calibration issue. I had to take the drone apart and calibrate each individual ESC manually by directly connecting the signal wires the the throttle output of the rxcvr. That method worked fine. The auto calibration method never worked. These are the stock 3DR ESC's too.

I would like a copy of the programming leaflet so I will contact 3DR support.

Thanks for your reply Michael.
That's the same issue I had. I did the individual calibration too. The auto calibration doesn't seem to work.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service