Hey gang,

I recently upgraded to the APM2.0 for my aerial video platform (F550 clone from Hobbyking). I followed all instructions and brushed up on my PID tuning skills, but on my maiden flight the helicopter had some seriously strange characteristics. First of all...here's my setup:

APM 2.0 with v2.6 firmware

F550 clone with integrated PDB

6x Turnigy Plush 30A ESC

6x NTM 2830 750kV motors

Turnigy 4s 5000 mAh 

Gemfan 10x4.5 props

Dx7 Tx & AR7000

AeroXcraft landing gear/camera mount

Pretty standard setup really. Now - as for the strange characteristics: on take off the copter had odd drift, very unstable yaw, very unpredictable throttle response, and it was generally un-flyable! I've gone through some PID tuning troubleshooting with the help of some folks on this site, but still no headway. After reaching a point of complete frustration I decided to revert to my last known flyable settings with my old HK KK2.0 board and HK Orange 6 ch Rx. Thinking I'd at least be able to get off the ground and have some fun until the new 2.7 firmware releases this week. WELL, I had the same problems but even more exaggerated! Terrible throttle response, weird pitch and roll issues (poor stabilization with verified settings from several days ago), and yaw was all out of whack. I've re-calibrated the ESC's both manually and automatically, checked prop rotation, board orientation and firmware, etc etc etc. I'm really flustered and don't know what else to do! Any help is greatly appreciated!

Cheers!

Will

Views: 6630

Reply to This

Replies to This Discussion

That is indeed strange, I mention the motor sound because I have a 1800gr hexa with the same approx specs than yours (xaircraft diy hexa frame vs your dji) and sunnysky 2212 980kv motors with 3s battery and mine lifts with a less rpm noise (using 10x4.7 props), but that can also be the motors that emit less noise. Have you tryied to reconfigure everything ? And I mean not only uploading firmware but, before doing that, going into cli mode, do erase and after, reset, and then, unplug the board, and reupload, and recalibrate radio. I'm suggesting this because I had a somehow identical problem wich I believe it to be corrupt eprom values and it solved re doing everything again. Another test you could make, would be connecting each esc to the RX ch3 (throttle usually) and test them to see if they respond correctly, because since you mention to be having those problems also on the other board, we might incline to rx issue, also, how are you powering the APM ? If you'r using BEC from the ESC, you should connect only the motor 1 servo cable with 3 wires and the other ESCs should only connect the white (signal wire) to the top row pin. If you're using a separate uBEC, you should set it as far away from the RX as possible, since switching uBECs can cause interference. I've seen some posts where people say it's ok to connect all the ESC BEC cables, however, from personal experience, I've seen what brown outs are :) and how they were gone after connecting only 1 cable.

I think this case is closed! After a lot of self inflicted hair loss I figured it out. 

All my troubleshooting lead to the direction Rui went with his most recent suggestion. I deleted some extraneous models in my DX7 and started from scratch. I set up a new ACRO model with no mixes etc and low and behold my KK2.0 board came to life like it was before I tried installing the APM2.0. I think where I went wrong is when I tried to set up the CH. 5 flight mode switch..I must have altered something in the Tx and made the thing go crazy! I'm anxiously awaiting the 2.7 firmware for my APM then I will re-flash and try to get my bird up in the air with the APM. 

Can anyone direct me to a thread for setting up my DX7 the correct way so I don't run into this issue again????

Thanks for all your hard work and insight, don't know what I would do without this support group!

Will

:) glad to see you have sorted it out. Version 2.7 is available, if you want to upload it via mission planner, update mission planner to actual 1.2 version and you have the 2.7 firmware available. Always perform a erase and reset before updating, it's a good rule and may save you some headaches. Sorry I can't help you with the radio, futaba here :P

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service