I ordered parts for two nearly-identical quads last December, for a pair of friends, for Christmas.  Slowly, I've been helping them put it all together.  I'm a noob to quads, but have some electrical experience.  I'm just not sure exactly how to isolate my problem to the offending part(s).

So, among other things, I ordered 2 openpilots, 2 4-sets of the Turnigy 250s, and 8 Afro ESC 30As.  We soldered up the the power distribution board and tested.  We got openpilot up and running.  It communicated fine, and we began going through the setup process.

the firmware upgrade (step 1) went without a hitch - CC3D rebooted and I proceeded with the wizard
step 2 (input signal) - selected PWM, multi-rotor, quad-X configuration
step 3 (output signal) - rapid ESC (that is right, isn't it?)
Then I made sure all the connections to the rotors were right, on channels 1, 2, 3, and 4 
Then I did the sensor calibration, which succeeded.
Finally it was time for the ESC calibration, where things did not go as expected.

I realize that this step gets a lot of press.  I've tried to do my research, but may not be savvy enough with how to search.  I'm finding lots of "not quite my problem" hits, so I thought I'd ask for help. I followed the steps carefully,   I checked the safety checkboxes, then pressed Start, then connected the battery.  At this point, according to some youtube videos I've seen, the "calibration beeps" referred to in the setup wizard should sound pretty distinctive, but instead of those beeps, I simply get a single tone that lasts a half second and repeats exactly every 5 seconds.  This happens indefinitely. On screen, the "High" is lit up in red, on the right, and the reading on the bar says 1900us.  I eventually press the stop button and disconnect the battery and move on with the wizard, but I don't get far.  During output calibration, it doesn't matter where I move the slider, the motors don't spin at all, so I can't find a neutral rate.

Thank you for any help you can provide in solving this problem.  I'm suspecting that there's something wrong with the ESCs.  Oh, I also tried hooking up the remote (FrSKY V8FR-2, with a DJT module plugged into my Turnigy 9XR-pro.  I can't get anything out of that, either.

Views: 162

Reply to This

Replies to This Discussion

And I don't have a signal generator or anything, or I might entertain the idea of trying to simulate one of the ESC's outputs to see if I can drive the rotors fine.  But I wouldn't suspect _all_ of the rotors to be bad (and, since the rotors are beeping, they're obviously not completely dead, or disconnected).  Nor, for the same reason, _all_ of the ESCs.  I'm guessing that I missed something important which is going to seem obvious in hindsight.  I just can't figure out how to get there.

Thanks again.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service