I just got my 3DR set and I can't get them to communicate with each other. The ground radio has always be solid green with the red flashing once a sec. The Air radio has been blinking green and red as if it was searching for the ground radio. I have followed the instructions over and over without any success.

I have used the FTDI cable also trying to do it directly through the computer with the same result. The MP only recognizes the air unit and loads all the initial information in it. From there I'm able to save the data from the air unit to the ground but it won't communicate still.

I'm thinking that the problem is with the ground unit because of the comm port. Every time that I choose the comm port for the ground it gives me one of two messages. "Failed to enter command mode" or "Failed to identify radio". This happens every time I try to do anything to it even to update the firmware.

This is my first purchase of this type of electronic, should I send it back?


Views: 9255

Reply to This

Replies to This Discussion

I assume you're choosing the right baud rate (57k) for the ground unit COM port, yes? If so, please contact tech support for further assistance. If you bought it from 3DR, that's help@3drobotics.com

Thank you, Yes I did (57K) and tried cloning the radios to have all same info. I bought mine from The DIY Drones, That's the same as 3DR right? Thanks for the e-mail

And you're absolutely sure you're selecting the right COM port for the ground unit? You can check in your Windows Control panel. 

Yup, Some times I have the ground radio by in self and it knows there is something plogged in to that comm port but it won't read any information from it or transfer anything to it eather.

I received an answer back from 3DR customer service. The LED behavior that I described for the ground unit could mean that there is something wrong with the Hope RF module.Also if I was to open the terminal tab I could see the error message from the radio. I was told to send it back so they can give me a new one. Very good customer service and she even answer a extra question that I had. Can't wait to get the new one and the I will update. ... Thank you Chris and 3DR :-)

Similar problem for me ..... almost.

The radio connected to the computer / GCS was showing solid green, and the radio on the 'copter was also solid with flashing red LED .... so the radios were talking.

I installed the 'Setup Executable' file as available at http://www.ftdichip.com/Drivers/D2XX.htm

I selected the 57600 baud rate.

I tried a different computer - one that the radios had previously worked on.

Repeated messages about not going to command mode. 

The solution: contact the crew at Bask Industries who came out to see me and rapidly determined that I was selecting the wrong com port. Simple!

The trick here... always check via the Device Manager what com port the radios are working through.  I'd assumed that as the drop down box indicated that I was using Com port 1: communications (forgotten actual word) that I was good to go.    Nope - select the com port as shown in the device manager and FIXED.

Perhaps the FTDI chip could be labelled with a 3DR tag or similar so that simple, but frustrating mistakes like this do not trip the noobs!

Thanks to Dave and Erdis.


Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service