Feiyu-Tech Gimbal and pixhawk

I'm having trouble getting the Gimbal's tilt control to work with mission planner/pixhawk.

It works fine alone, leveling etc.  When I try to pass through tilt control to RC through the pixhawk it just goes straight down and wont move at all.

I've double checked that my RC input is calibrated and that the connections are right...is there something special I'm missing?  If anyone has used one of these, details on your setup would be very helpful! thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Which one, up or down?

    (PWM OR ANGLE LIMITS)

  • Adjusting the parameters in mission planner should solve your problem.

  • Ok, I have finally made some progress in setting up my Feiyutech gimbal where,  'Point camera here' and ROI seems to function as intended however,  it would be nice to have the subject (of the ROI) a bit lower in the shot/frame.

    Does this mean I could adjust the PWM values  up  or down within mission planner?

    Or just adjust them on the Taranis?

    (I'm a little exhausted of trial and error with no result.)

    Note: I'm running the same auto mission over so as to see the change but.... no change

  • Does the follw you function work for you because my gimbal isnt looking at me other than that everythng is working just fine now with that setup
    • ahh I haven't tried that, but I doubt it would work since the FeiYu uses pan for the yaw axis. When you change the yaw pwm it would just keep turning in one direction, i.e. the yaw pwm doesn't correspond to the actual yaw of the camera

      • I was actually just thinking about the pitch, tilting the camera down to keep me in frame since Irisi+ will keep "looking" at you al the time

  • Hello! First post at this forum!





    I have to ask you or anybody else who knows the answer. I am right now very close to success and have got all the controls working, I have tilt (ch6) I have pan(ch8) and I can control with ch7 as well. However I have one problem left and I don't know how to solve it.


    The gimbal doesn't look forward? >It either looks straight down or backwards, straight down being the most forward position after I have turn P3 and backwards being what should be straight down but is backwards.





    So what to do in mission planer? I have the settings just like you have but it really doesn't any difference what value I punch in under tilt.


    I fly an 3DR Iris+ with Feiyu tech Mini3d gimbal





    (I have already flown with the gimbal but then without any pitch control an then the camera was pointing forward, now I cant get it back)

    • Hey Christian

      I fly one of these with full stability pan and tilt, and three modes. After wiring, mission planner setup, and transmitter setup, it should be fine.

      One of the other things to check is to make sure the inital orientation of the gimbal (at the roll axis) is as pictured on the Feiyutech Pictures.

      If I can help to describe more the wiring etc, let me know, but I'm pretty sure you have all that correct.

  • Hi Ian,

    Would these steps apply to a Spektrum DX8? Have you solved the issue with the auto missions?

    I am about to get a FeiYu gimbal. I don't see anything else in the market that would work better with Pixhawk.

    Thanks!

  • Erik, have you resolved your issue with this? I have managed to get control of my Mini 3D Pro on Iris+ via my stock transmitter. A quick guide as follows:

    Quick Guide to Installing FY Mini3D Pro gimbal to Iris+

    Instal gimbal and connect wires from gimbal to Pixhawk as follows:

    Blue (Tilt) wire - Pixhawk AUX OUT 1 (wire connects to bottom/signal (S) pin)
    White (Pan) wire - Pixhawk AUX OUT 2 (to bottom/signal (S) pin)
    Black/Brown wire - Pixhawk AUX OUT 3 ( brown wire connects to bottom/signal (S) pin)
    Connect Black/Red wire to factory fitted Black/Red wire coming from vents on the underside of the Iris+


    On the transmitter menu 'MIXER' page (5/10), copy the settings of Channel 7 down to Channel 8. Then edit Channel 8 changing the Source to P1 and Switch to nothing (---).

    Connect Iris+ to Mission Planner (MP) (I found it best to use the 3DR Telemetry Radio connected to the PC and power the Iris+ with the battery). In the Configure/Tuning menu of MP, click on Standard Params and scroll down to Channel 7 option and Channel 8 option and change from 'Land' to 'Do Nothing' in the drop down lists. Click on 'Write Params' to save to copter.
    In the Initial Setup menu of MP and click on Camera Gimbal. Next to the word Tilt the drop down list should already say 'RC9' and over to the right of the graphic for Tilt the drop down list under 'Input Ch' should already say 'RC 6'.
    Now next to the word 'Roll' change the drop down to 'RC 11' and the Input Channel for Roll to 'RC 7'.
    Then next to the word 'Pan' change to 'RC 10' and the Input Ch to 'RC 8'.
    Disconnect MP from the Iris+ and re-boot the copter.

    Now with the CH7 switch in the ON position you should be able to control the Tilt of the camera with the Tilt dial and the camera will pan automatically to follow the nose/heading of the copter when it is moved.
    With the CH7 switch in the OFF position the camera will automatically remain pointed in the direction it was set when switching CH7 to off, when the copter is moved. You should also be able to control the Tilt of the camera with the Tilt dial and control Pan movement with the dial in front of the Tilt dial (Channel 8).

    If all was successful, re-connect Iris+ (powered by battery again) to Mission Planner with power to the gimbal and camera switched on and run the 'Calibration Wizard'.

    I do have a problem with getting Pixhawk to control tilt in auto missions to point at ROI though!

    image.jpg

    http://copter.In/
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…