Hey guys, so after 9 months I finally got my large quad in the air. I changed ESC's from afro 30a to Hobbywing 40a. I went 40a just because. Anyway, I am running a pixhawk on a x650f frame that has been stretched. I am using 4114 330KV motors with 15inch props. So after changing out ESC's she finally gets into the air.

The issue now is that it does not hold throttle properly. Say I am at 40% throttle on the transmitter and I hold it there the quad does not respond properly. It will throttle up shoot up in the sky and then throttle back down so far that is come falling out of the sky. I can at least keep it from crashing but something is not right.

So here I am asking for help from you fine people. I've included the log of the last flight as well as backup of my setup file from mission planner. Thanks for any help guys!

Views: 356

Attachments:

Reply to This

Replies to This Discussion

Did you even do the ESC calibration of the new ESCs ?


Andre K. said:
Did you even do the ESC calibration of the new ESCs ?

yes that is the first thing i did

Not sure what props you have, but it looks like a 6s battery.  Maybe too many volts for the pitch / motors?  Did you check the config on ecalc?

RC3_TRIM should be = RC3_MIN

not sure if that's the whole problem - but try that first.

Tyler:

I'm flying a Tarot 650 frame with Tarot 4114 330KV motors, 15 inch props, a 6s battery, and a Pixhawk clone controller running Ardupilot 3.4.6.  I've never had a problem, and I haven't even completed a full auto-tune yet.  You can find a complete parameter dump from my quad and a list of differences between my config and your config at: https://gist.github.com/larsks/933b7c7d80093a71790439eafcd5d077

You can ignore a chunk of that (e.g., compass and transmitter calibration values), but maybe something there is interesting. I don't know enough to offer any specific suggestions.

Tyler,

I don't see anything fundamentally wrong other than you were flying in Stabilize mode with a significantly over powered craft.  As such, you are controlling the copter altitude manually with the throttle and small inputs can cause large altitude accelerations in that mode.  Try flying in Altitude Hold or Position Hold modes and it should fly fine.  It looks like you are running the latest (or later) version of the APM firmware.  I could not find the THR_MID parameter in the param file (it may be gone in later FW versions).  That parameter allows you to scale the throttle mid-position so the copter will hover mid-stick in non-altitude hold flight modes.  Your copter was hovering with about 25% power.  You should try to match the power and weight so it hovers closer to 50%. 

In the later versions, the MOT_THST_HOVER parameter is used to set the throttle mid position in non-altitude hold modes.  See the section on Tuning and follow those procedures.  That should get you there.

http://ardupilot.org/copter/docs/ac_throttlemid.html

You might want to check your prop balance as there was a significant vibration in the Y-axis.  This can sometimes cause stability problems.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service