I can not seem to understand what is happening here and I thought I would reach out for some assistance. 

After flying in stabilization mode for about 5-15 seconds the quad will slowly start to pitch harder and harder to the aft of quad. I fight it with the RC stick controls but eventually the pitch compensation is not enough and I have to land, it happens quick, I haven't had a flight last more than 1min. It is almost like the craft if trying to compensate for something and is slowly learning to apply more pitch to the aft of the craft.

After landing, power cycling, then taking off again the craft works for a minute then starts to pitch aft.

I am running the latest stable 3.1 firmware and Mission Planner. I have done a compass and accel calibration, Mission Planner indicates proper axis control when I move the craft while plugged into USB. 

Prior to flashing the firmware I did an erase, reset, and radio command to start fresh.

What am I missing? I am going to try a telemetry flight and record the details to post.

PS. I do not have anything covering the barometer right night now, but I didn't think this was an issue unless I was trying to do Alt. Hold.

Views: 538

Reply to This

Replies to This Discussion

Bad vibrations, balance props, use some vibration damping of APM
Try resetting everything again.

Okay I have done the following

- Added some vibration dampening to the APM 2.5 board (has double sided 3m tape on the 4 corners 3 pieces thick)

- Balanced Props (I did notice a vibration reduction upon takeoff)

- Secured battery better (just in case it was throwing CoG by shifting)

- Updated firmware to 3.1 (again)

- Executed "reset" command

- Ran setup wizard and followed through

- Board is at 90deg YAW orientation, so I changed that, wrote config, restarted APM

- Ran compass & accel a second time

Upon flying this time it pitched forward instead of aft. It is so strange because it starts off so little and within 10 seconds it becomes too difficult to control. If I land, disarm, arm, then give a little throttle it tries to flip the quad forward over back. If I power cycle then it works fine for a few seconds then reverts. 

Is there anything in the telemetry log I can be looking for?

Did you double check APM is pointed forward? Also, make sure you run level setup. What APM are you running?

I am running a one year old APM 2.5 with the internal compass. I seem to have resolved the tilting, not exactly sure what did it but now since I am using Andropilot for telemetry I have been getting occasional "check mag field" errors that preventing arming. Resetting it usually fixes the issue but I wonder if that is what is causing my problems. I think maybe an external compass may be in my future. Thought?

If you're getting a mag field error at all then you have issues. Have you run compassmot? It may help a bit but I found the only real way to make it bulletproof is to reduce EMI. Even with an external compass I found the positioning of power wires quite critical. Your best bet is to get all power related items (ESC's, motor wires, battery wires etc) all as far away from the APM as possible. I was able to force all mine underneath the power distribution board and my mag field error is about 8% when running compassmot. Before it was around 30% and I'd have a similar issue in loiter, it'd sit there fine for a few seconds then quite quickly start drifting off.

This looks very similar to an issue I am having with my quad.  I cannot get it to lift off, it tries to flip on takeoff.  Have checked the usual suspects, motor rotation, props and motor positions and TX trim.  I have noticed with the APM plugged in by USB it is fairly stable when horizontal but add a bit of roll and the pitch and yaw start moving all over the place.  I ran a test with no main battery attached just to get the log, therefore no motors running.  I started horizontal when I armed then rolled it to about 65° and left it sat on it's arms.  Watching the readouts the ax, ay, az... through to mz and magfield all stayed fairly static but the pitch is going up and down, yaw is going left and right. 

Looking at the log there is almost a sinusoidal waveform for each of pitch, roll and yaw, although the roll wave is less pronounced.

In my case during takeoff the board seems to detect excessive pitch which is increasing, the board tries to compensate by increasing the motor speed on the opposite side.  In reality there isn't any pitch until the board tries to compensate which flips the thing.

I've now got the board off the quad to make sure it's not an EMF issue but it's behaving exactly the same.  Running 3.1 stable at the moment.  Didn't have any problems with 3.1RC7 and updated to stable after a crash and re-build, I've not been able to get a stable flight since I updated.


On yours Andrew, check the voltage on the I2C port and see if you are getting the correct 3.3V or 5V which indicates a bad regulator. There is a thread where Randy made a video showing how to check it. This should be the link - http://diydrones.com/forum/topics/ac3-1-rc5-spi-speed-problem . I don't think this is the OP's problem but rather that looks more like a vibration problem or maybe acc drift from a bad chip.

Okay, I have tried searching on this and came up with no results. This is my 3rd quad build and the only one I directly hardwired the ESCs to the the batteries. There is no power distribution PCB on this quad, like I have on my other two. Instead I just wired everything together and it sits in a circular arrangement about 1.5" under the FCU, have I made a grave error in how I have set it up? Also, I did read that this wasn't the greatest idea, but I have the ESC sitting on the end of the arms adjacent and beneath the motor, meaning the power runs from the center of the quad all the way out each arm. I will take some pics to show.

I am going to attempt running compassmot and see what happens. I do notice that it happens in specific areas more frequently.

I have two major fly areas and one gives me the error 10% of the time while since I installed the current/volt sensor, the other does it 80% of the time, I basically reset it move it, try again. I also notice that the position of the vehicle moves erratically at times on the MP even when outdoors and sitting on the ground (allowed to rest for 5 min before attempting anything). I also got the tilt issue the other day and when I looked on the MP it was hard tilted just sitting level when doing a "Manual level" it did not move, not until I power cycled did it reset to level.

On my 800mm hexa I also have power wires in each arm reaching to the ESCs near motors. Though compassmot is not very good (85%) on the elevated APM 2.5 (internal compass), my loiter with 3.1 is nice and the first auto mission I've run yesterday with auto take off and autolanding was really precisely accomplished, except for a too slow final descent rate (I'd set it to 20cm/s) making it difficult to touch down. PIDs are standard, without autotune, Just had to lower I by two clicks to eliminate toilet bowling on faster descents.

COuldnt it be that your motors are wired up wrong ? Have you tried nudging back on the pitch while on the ground to see if the front lifts ? Can you lift the back by pitching up just a bit. When i say nudge i mean on low throttle, but enough on the pitch stick so the copter can lift one edge ? Repeat the same for the roll axis, try and left on the left and right.

Wanted to update this thread just so everyone knows what my issue was.

1) I installed the CN06 Plus by RCTimer which isolated the FCU for vibration and moved the FCU further from the ESCs

2) This also installed an external magnetometer

Once configured the quad flies like a dream. I have flow 2.x before but wow 3.x is amazing! The ability to hold position is better than any of the platforms I have seen.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service