I need to know about confirmed operation....

In other words.... When I switch flight modes, How do I Know if it actually does????

My Taranis is telling my it's changing but I would like some kind of feed back from the model that the mode I select is armed....

Is this possible?

Views: 1424

Replies to This Discussion

Thanks Henny V, I'll check it out....

Ok... A friend had a  Mavlink Telemetry adapter From Droneshope and it works but I'm not getting one flight mode feeding back and Auto Tune and Return to home are not responding either....

But now my Mission Planner wont connect???

Hi David

Can you confirm you are running Opentx on your Taranis. I have this Droneshop option on my Hex and it works just fine, however its was a bit involved in getting it to work correctly. Peter from the Droneshop has a installation video on Youtube. The Video specify s all the necessary steps including loading the new voice library as well as loading Open TX. You indicated your friends Taranis is working which should be enough to indicated it can work if you follow the required steps. You did not indicated all the components you have on your machine.

Yes Mission Planner sometimes wont start, ensure the USB cable is fully in and restart mission planner a couple of times.

Good luck

There are multiple ways. The most common ones are:

1. MinimOSD with a video overlay showing flight mode

2. 3DR radio to ground station

But there is nothing that prevents you from listening in on MavLink telemetry, and turning on LEDs depending on flight mode. Could easily be done by an Arduino Pro Mini.

Yes, I am running OpenTX and all seems to be working apart from a few things....

I think I might need to go over my settings in Mission Planner again but that not working now...???

My friend gave me the Mavlink adaptor he no longer uses and we set it up last night.

I now have extra screens with lost of telemetry data on it including a message showing what flight mode I'm in and a audible confirmation of that too....

Just my position hold, auto tune and return to launch do nothing....

I need to get MP working before I go any further.... Perfect flying weather too! :-(

Ok.... I'm getting somewhere....

I have the Mavlink working and I've found I can connect to Mission Planner on my wifes laptop running Windows 7 (mine is old and running 32 bit XP!)

A new problem is that I can't see the drop-down options for flight modes????

I took the Hex out for a quick flight and it all seems to be working ok... ish....

I found and old version of MP (1.3.31) and it all works! 

I need a brake!

Now it's working... I can spend some time setting this thing up properly.....

You shouldn't have to use an older version of the Mission Planner. I am running the latest version of the MP, along with the Pixhawk FC and the 3DR Radios for telemetry.


Whenever I flip my TX into a different flight mode, the MP reports what mode that I am flying in. I reckon its a setup issue. Take your time, do some troubleshooting and I would recommend not rushing through these things, as its very easy to overlook something and make a mistake.

Unfortunately, the latest version is 64bit... unless I run on my wifes laptop....

Or get a new one for me????

Anyway, I do plan to go through the set-up... the weather for the next few weeks looks rubbish so that's my chance....

 

+1 for the Craft and Theory cable and Taranis screens/scripts

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service