Underpowered quad problem (clone pixhawk issue?) [renamed post due to TOS]

Whats up yall. So there will be profanity in this post. If you have small children have them look away now.

I am on my last wit here. If this cannot get fixed, I will post a video of me blowing up this f*****g quad in some shape or form. All work Flawlessly and the issue came out of absolute nowhere.

So............. New Motors, New ESC's, ALL new wiring. Only the bare essentials connected. Reinstalled Pixhawk firmware. Re-Flashed pixhawk. Re-Flashed Devo Transmitter. Tested quad with pre-arm off. Re calibration of pixhawk. Tried again. Removed power module. Powering pixhawk with 5v leads from ESC's.

The quad cannot leave the ground......It seems as if the quad is EXTREMELY under powered. When at full throttle, the thing runs for a few more seconds, then a full blackout. I mean FULL blackout. ESC's, Flight Controller. even with the battery connected. To power back on, The battery needs to be unplugged and plugged back in again.

PLEASE PLEASE PLEASE PLEASE PLEASE help.....................................for god's f*****g sake.

P.S. I intended on using more profanity.....

Views: 5262

Reply to This

Replies to This Discussion

Check your THR Max parameter, I have had an issue when i had just flashed new software and it was set to 100 (which means 10%) and fixed it by changing it to 1000 (100%). Doesn't help with the brownout though, assuming you are using only one and not all of the esc's to power it because that can cause issues depending on the type of bec in the esc.  

Been there.

1- Try a firmware rollback.  Helped me once, and that is an easy way to verify that your mechanicals are working.

2- Try re-calibrating your radio. EzUHF gave me fits for a while.

3- As listed elsewhere: check Throttle MIN, MAX, and MID.

4- Tell us what worked.

Can we get ANY data of your quad??picture?video?Anythng...

I suspect he's realised that he's a fool and won't be back.

Sorry yall. I'm still having the issue, just been troubleshooting this thing left and right. It's looking like something is actually wrong with the Pixhawk....

@Checkers, I haven't tried that fix yet and will when i get home and let you know how it goes. 

Here is a video of the issue at hand. 

https://www.dropbox.com/s/60l3mpy4doo5hct/20150506_135344.mp4?dl=0

My guess is a power issue / ground loop somewhere.

Somehow you're trying to pull power through the pixhawk or BEC and it's tripping (there is a resettable fuse in the Pixhawk).

How have you wired the ESCs and BEC in? (If any bec).

Do you have Signal + ground going down to ESCs from Pixhawk.

The BEC signal and ground are connected to the pixhawk, I clipped the 5v leads so they are no longer connected to the pixhawk, The pixhawk is being powered from the power module. Where is this reset-able fuse you speak of?

Attachments:
It's not user resettable. Does when load is removed.

Check and recheck your negative from battery to esc.

Try removing ground from one esc signal at a time. It might highlight where the fault is.

Try measure voltage over the power module shunt. ie put a tester on the positive on the battery side and the other lead on the non battery side of the red wire. You should see a very small voltage, millivolts. Could be a dry joint on the shunt which bends open under load from heat.

Just thinking out loud of things I would discount.

So try the ESC signal wire without the grounds? And what do you mean by shunt?

~SA

@Crispin, "I suspect he's realised that he's a fool and won't be back."

Your comment is harsh, please consider removing it.

Yes, one at a time. My thought is that one of the esc is pulling power via the signal ground which causes everything to get grumpy. Do check and recheck your wiring first. If you have a tester then check for continuity between battery plug negative and each esc negative. Disconnect the pixhawk signal. There should always be ground continuity.

If you are using the 3DR power module, there is a current shunt in there (Google). It might have a dry joint which fails when loaded up.
Put a voltage meter on each side of the red wire.


BTW, hope quad is tied down. Testing like this with props on is going to lead to disaster.

I have to keep the props on. This only happens when props are attached. If i disconnect one motor (Any), the issue doesn't happen. Already sliced my hand open xD

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service