Just bought a new transmitter from Hobby Partz. (Put the batteries in it. Fully charged.) Made sure all the switches where in the right positions. Turned it on, it just beeps, and display "switch error" message? Switches are all forward. So does this mean this transmitter is defective?

Views: 787

Attachments:

Reply to This

Replies to This Discussion

I have 3 of these 9x machines and with one I had to experiment to find the one switch that wanted to be in a different position...so before you panic, play with the switches and get to know your TX... They are great radios!

I tried flipping different combinations switches. No luck. Still beeps and flashes "switch error"?

Turnigy FlySky iMax Eurgle 9X Switch Error: http://youtu.be/GhwOWtcagnA

Yes I already saw this video. It doesn't help me with the transmitter problem. All switches forward, away from me. Still get the flashing switch error.

Throttle is high

Try lowering all the way to the bottom and retry

Didn't work. Got a hold of Hobby Partz and trying to send it back for another transmitter. All I'm getting from Hobby Partz is the run around. 5 emails wanting me to explain what's wrong with the transmitter. I sent photos, even took a video of the problem. Waiting for a response about the video?

Finally got an RMA number from Hobby Partz to send back the defective transmitter. But it looks like I'm going to get stuck paying the shipping return? (Which is wrong.) Not sure if they are going to charge me 15 percent for a restocking fee either? I took a video as "proof" that the transmitter wasn't working and was defective so they can't say otherwise and try to charge me a restocking fee for their defective transmitter.

Just before you ship it back. Would you mind to send us a picture of the top as well. There might be something small wrong. I have read a lot of people asked about this and in general the radios aren't faulty I have only come across two people with faulty units and one of the did not have the same problem. 

if you can bypass the error screen by pressing a menu button, go thru the calibration screen, and adjust the throttle.

check to see if that works. if not, then go to the limits page, and offset or lower the output on the low side to below 900

other then that, Im not sure.. 

JohannAll switches are forward, transmitter just beeps, and flashes "switch error". I also tried different combinations of the toggle switches forward with no luck. (Believe me, I prefer not sending this transmitter back.) I've been working on this project since June. Its just been one set back after another.

Bill I pressed the menu button, nothing. I tried different combinations with the switches, all it did was beep and flash switch error?

That photo shows your throttle all the way up to max.
Try moving it all the way to the bottom.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service