Gas powered Hex, stuck on the ground

OK.. I have built 10-15 tri,hex,octo… ect all with AMP 1   2   2.5… 

 All worked fine…for the most part..

 Now I am building generator-copter…  23CC gas motor powering a 2000 watt brushless motor..

 To date the generator has produced over 1100 watts….  70 amps at 16 volts… 

 Test results show at this weight I need 7-800 watts to lift this noisy beast…

 A few days ago I was ready to start testing the copter itself…  APM 2.5… Hex…  with 17” CF props

http://www.rcgroups.com/forums/showthread.php?t=1795491&highlight=www+jetlen+com

 

But major problem…   ESC’s will not arm on power up…..   When plugged directly into receiver… They Arm no problem, and calibrate like normal…and run the motors..

then I plug them into the APM 2.5…  nothing… I get 3 beeps... thats it...

 

I Measure the PW on the output rail… 1002ms…  I plug a servo into the output rail… works great… Arm the APM 2.5.... power up… servo moves…ok

 

I plug the APM into the usb, the APM boots up…. Then I plug in the Main power… 4S with 5 volt BEC…  ESCs boot up no problem, and I can run the motors…

 

Summay… The ESCs only ARM when the APM is power up first !!!....whats up with that….??

 

Here is the setup…

 

APM 2.5… tried 2 different ones… 2.9.1

All ESC have the red wire cut…

5 volt set to 4.9 and 5.2….. no difference..

Jumper installed… not installed…   even jumped the power from the input rail to the output rail like I always do…  nothing….

Detrum 25A ESC 2-6S

Hitec receiver…

Thanks for your help...

 

Eddie Weeks

3691005998?profile=original

3691005923?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I guess you saw my suggestion on your RcGroups thread to power the APM first ;)

    Have been battling this arming issue for quite some time. The frustrating part is that it's only a few ESCs affected and that the issue was fixed in 2.6 and 2.7 but is back in 2.8 and 2.9.

    http://diydrones.com/forum/topics/esc-arming-issue-turnigy-plush-40

    -----------------------------------------

    Latest state for my equipment

    -----------------------------------------

    As far as I can tell this issue is back in 2.8 and 2.9. Arming worked fine for all my ESCs in 2.6 and 2.7.

    However with the current 2.9.1 version, several of my ESCs never initialize properly (the ESCs are a different "version" of the same Plush 40 ESC model). My workaround to first boot the APM with a separate ubec and only then power the ESCs still works fine but is a dangerous hassle.

    I went one step further and put a switch on the signal line of the problematic ESC. During boot, the switch connects the signal to ground. Once the APM is booted I flick the switch to connect the signal line. Then the ESC happily initializes.

    Since this problem was fixed in a previous AC version, it would be great to get that behavior back. ArduPlane 2.70 actually now has the same problem.

    Any insight on what was done to fix this problem in the first place and whether that fix was removed by mistake?

  • Really great design.

    Just a few thoughts Eddie,

    Do you normally have a battery in the system?

    If you do not have a battery is there any sort of regulation that prevents power from going to the APM before it is at least at 5 volts and smooth?

    If the answer to both above is no then you are attempting to bring up voltage slowly to the APM, and ESC's.

    This means that the ESCs will be out of sync with the APM while powering up and will not initialize properly.

    Also very not good to power APM with less than 5 volts, it may not self initialize properly at all.

    I honestly think that the prospect of powering the APM from a small separate battery (and UBEC) is an easy solution, you could always include a small charger circuit for the battery, but the smooth power could really help.

    If you do that definitely use at least a 2 cell LiPo and a UBEC rather than trying to power the APM from a 4.8 volt battery.

    This is a really great project that could yield really long flight time Multicopters and I wish you all the best and can't wait to see it flying.

    Damn just sold my Traxxas Monster Buggy too, I always knew that Zenoah engine could be good for something.

  • T3
    Very cool design. Scary but cool. Good luck.
  • It sounds like the ESC's are not seeing the right voltage when they are armed.

    How do you initiate switch on, is it just ramping up the motor/generator until voltages get high enough to power everything, or do you ramp up the motor/generator to voltage and throw a switch?

  • BTW.... I could just plug a 4.8 volt batt into the receiver then power up the copter... that works... 

    But I want this to be done right..

     

    Just saying

This reply was deleted.

Activity

Abdulatif Tlaib liked Ryan's profile
8 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: First time at @wsraceways. After tuning @HokuyoUsa lidar signal and camera sensor on @NVIDIAEmbedded, my car was able to…
Sunday
DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
Jun 18
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
Jun 18
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
More…