OK.. I have built 10-15 tri,hex,octo… ect all with AMP 1   2   2.5… 

 All worked fine…for the most part..

 Now I am building generator-copter…  23CC gas motor powering a 2000 watt brushless motor..

 To date the generator has produced over 1100 watts….  70 amps at 16 volts… 

 Test results show at this weight I need 7-800 watts to lift this noisy beast…

 A few days ago I was ready to start testing the copter itself…  APM 2.5… Hex…  with 17” CF props



But major problem…   ESC’s will not arm on power up…..   When plugged directly into receiver… They Arm no problem, and calibrate like normal…and run the motors..

then I plug them into the APM 2.5…  nothing… I get 3 beeps... thats it...


I Measure the PW on the output rail… 1002ms…  I plug a servo into the output rail… works great… Arm the APM 2.5.... power up… servo moves…ok


I plug the APM into the usb, the APM boots up…. Then I plug in the Main power… 4S with 5 volt BEC…  ESCs boot up no problem, and I can run the motors…


Summay… The ESCs only ARM when the APM is power up first !!!....whats up with that….??


Here is the setup…


APM 2.5… tried 2 different ones… 2.9.1

All ESC have the red wire cut…

5 volt set to 4.9 and 5.2….. no difference..

Jumper installed… not installed…   even jumped the power from the input rail to the output rail like I always do…  nothing….

Detrum 25A ESC 2-6S

Hitec receiver…

Thanks for your help...


Eddie Weeks

Views: 1079

Reply to This

Replies to This Discussion

BTW.... I could just plug a 4.8 volt batt into the receiver then power up the copter... that works... 

But I want this to be done right..


Just saying

It sounds like the ESC's are not seeing the right voltage when they are armed.

How do you initiate switch on, is it just ramping up the motor/generator until voltages get high enough to power everything, or do you ramp up the motor/generator to voltage and throw a switch?

Very cool design. Scary but cool. Good luck.

Really great design.

Just a few thoughts Eddie,

Do you normally have a battery in the system?

If you do not have a battery is there any sort of regulation that prevents power from going to the APM before it is at least at 5 volts and smooth?

If the answer to both above is no then you are attempting to bring up voltage slowly to the APM, and ESC's.

This means that the ESCs will be out of sync with the APM while powering up and will not initialize properly.

Also very not good to power APM with less than 5 volts, it may not self initialize properly at all.

I honestly think that the prospect of powering the APM from a small separate battery (and UBEC) is an easy solution, you could always include a small charger circuit for the battery, but the smooth power could really help.

If you do that definitely use at least a 2 cell LiPo and a UBEC rather than trying to power the APM from a 4.8 volt battery.

This is a really great project that could yield really long flight time Multicopters and I wish you all the best and can't wait to see it flying.

Damn just sold my Traxxas Monster Buggy too, I always knew that Zenoah engine could be good for something.

There is no battery in the system....  other than the 10000 mah 4S....  which goes to a 10 amp UBEC

where I set the voltage from 5.2... to 4.9...   no difference....


I think what you said about the ESC will be out of sync with the APM wile poweing up is the problem....

I tried one other ESCs and it worked fine on this setup...   After flying today where each ESC was using 5 amps

30 amps to hover... and each ESC  was getting very hot till one faided ....   I think these ESC's are just not good enough......  They are 25 amps and very cheap...  Its a risk getting cheap stuff, but I have not had any problems with cheap ESCs till now...

Also I am running 4S on Large 350 KV motors and these ESC are not designed for that... I guess..


During the short flights this HEX flew fine... as I knew it would...  2.9.1 stock can fly anything...stock setting... will tune down yaw... but that's later...


But at 4550 grams and 30 amps to hove it comes in at 9.4 grams / watt....  Very good results..

Thats with 2 x 5000 4S and a Fluke meter..

when the generator (3.6kg)  is installed that should go down to ~7 grams / watts... but still no problem...

It uses 17 x 5.5 props...  and is very quite... for now...


The more I think about it... These ESCs are stupid.. !!  ... LOL....  so what if they don't get the right PW

right on power up... with in a sec or two they are getting 1002 ms... they sould then ARM...  AGGGG...LOL...




There will allways be a mid size battery on board...  If the gen quits... can still land....

I have a Mix on my radio that powers up the gen as I power up the copter...  I was able to keep the

voltage right around 4.0 volts / cell even with ~60 amp load


Here is an early test with a different copter as the load..




Well another ESC not working with APM 2.5... I don't get it...


All these ESCs (6 x Detrum 25A) and 1 Scorpion 60 will not arm with APM 2.5..


They work fine with receiver.. but thats it. !!!


What am I missing. ?




I guess you saw my suggestion on your RcGroups thread to power the APM first ;)

Have been battling this arming issue for quite some time. The frustrating part is that it's only a few ESCs affected and that the issue was fixed in 2.6 and 2.7 but is back in 2.8 and 2.9.



Latest state for my equipment


As far as I can tell this issue is back in 2.8 and 2.9. Arming worked fine for all my ESCs in 2.6 and 2.7.

However with the current 2.9.1 version, several of my ESCs never initialize properly (the ESCs are a different "version" of the same Plush 40 ESC model). My workaround to first boot the APM with a separate ubec and only then power the ESCs still works fine but is a dangerous hassle.

I went one step further and put a switch on the signal line of the problematic ESC. During boot, the switch connects the signal to ground. Once the APM is booted I flick the switch to connect the signal line. Then the ESC happily initializes.

Since this problem was fixed in a previous AC version, it would be great to get that behavior back. ArduPlane 2.70 actually now has the same problem.

Any insight on what was done to fix this problem in the first place and whether that fix was removed by mistake?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service