I have some questions, but first let me tell you what I have done so far. I have my arducopter assembled, all ESC’s calibrated with the following calibration:

 

 

 ESC Tower Pro w25 settings Brake-off, Battery type-Li-Poly, Cutoff Mode-Soft, Cutoff Threshold-Medium-High, Start Mode-Normal, Timing-Medium.

 

Motor-Turnigy 2217 20turn 860kv 22A Outrunner Motor spacing is about 51cm

 

APM and IMU Fatubu T6XH radio with 4500mAh battery.

 

My questions are:

 

Are the ESC setting correct for theses motors and application?

 

What mode should I start off with to try to get it in the air for the first time?

 

What PID settings to start off with?

 

Thanks for any help,

 Scott Quartochi

Views: 2016

Reply to This

Replies to This Discussion

I use the same motors and Turnigy Plush 30A ESCs. I did the calibration for my ESCs and left the default settings for everything else.
For the Turnigy Plush 30A, they are:
Brake Settings: Disabled
Battery Type: Li-xx
Cutoff Mode: Reduce the output power gradually
Cutoff Threshold: Medium
Startup Mode: Normal
Timing: Low


Now, I don't know if these settings are ideal, but I have gotten my ArduCopter in the air with them. Hopefully someone with a little more experience with these ESCs will comment.

I have been using the acrobatic mode myself for the moment because it is actually more stable for my quad than stable mode.

I know my PID settings have to be changed, but for my first flights, I just left them at the Default settings which are initialized when you click the EEPROM button in the configurator, but they can each be changed individually.


If you have someone hold the quad over their head, you can fine-tune the PID values. BUT BE VERY CAREFUL DOING THIS. Have them tilt the quadcopter and feel it trying to stabilize itself. Keep increasing the P value until it is very stiff and difficult to tilt. If it starts to oscillate, lower the P value. Do the same for all the axis-Roll, Pitch, and Yaw. The PID values will differ based upon weight, motor distance, and other factors.
Acrobatic Mode PIDs:


Stable Mode PIDs:


*The pictures will be enlarged if clicked on*

Scott, you've probably heard all of this about tuning PIDs before, but for others who are looking into the ArduCopter project and see this thread, it might be useful. I hope you get yours flying!
Now when you say increasing the P. are you connected to the usb or do you have Xbees?
I just use usb because I don't have Xbees yet, but I imagine the Xbees would be very handy for tuning the PIDs. The ardupilot mega folks have a nice writeup on configuring the Xbees here. Hopefully they work well with the ArduCopter configurator.
Ok thanks for the info, but what I am finding every time I have an question answered another pops up. Did you just unsolder sj1 and power the board with USB. The docs say never to connect the usb and battery at the same time. I have already fried one APM, don't want to do it again. I would love to see whats happening with the system when its running.

I have two Xbee’s but no adapters yet. I have spent around 450 dollars so far and the boss of the house noticed  I will have to get them at a later time.
I haven't gotten around to playing with my PID values yet...I am waiting on a motor because one of mine stopped working. But, since I'll just use usb without Xbees, I guess I'll remove the battery power, connect to computer to update PID values, remove usb, reconnect battery power. It will be a slow process that way, but it should work. I didn't unsolder sj1
Thanks again
Well tried again today with no sucses. It just wants to flop over.
That's how mine was at first. One thing I discovered was that the aux channel on my transmitter that switches between stable and acrobatic mode was bound to the throttle. So, as I increased the throttle for takeoff, it would reach a point where it switched between acrobatic and stable mode. I have a Turnigy 9x and it was in helicopter mode...I switched it to airplane mode and it is no longer bound like that.

I'm not sure how you are taking off, but in my case, I was very cautious on takeoff. I would apply the throttle very slowly and then the quad would lift off first on the right side. So, I would decrease the throttle again so it wouldn't flip over. Looking at the raw sensor data in the configurator, I noticed a range where I could increase the throttle so slowly that it wasn't registering a change in the sensors for the motors to compensate. My theory was that I needed to be more aggressive with the throttle and that once in the air, the quad would be able to stabilize itself. I didn't want to break anything, so I took an old cupboard door, drilled some holes in the door underneath where each motor is, and tied a rope to each arm of the quad so that it couldn't flip over. With it tethered, the increased throttle seemed to help, but I needed to try it untethered to find out for sure. So, I took it into the field with longer grass to cushion it if it flipped, but it flew! Maybe rig up a tether system and try something like that?
Anyone else have feedback for Scott?

Really low-res video:
Thanks, man I am just so scared of the crash. I had it like 12" of the ground and it tilted so I killed the motors ( I am applying the throttle very slow). I will have to come up with something.
Tell us more about your quad. + or X?
What direction are each of the motors spinning?
What props are on which motors?
When it gets off the ground does it try to rotate?
Does the arm and disarm work correctly? Right to arm, left to disarm.

Mine used flop over when I first tried it.

JC
It is in +, I have 2 APC 12x3.8 Slow Flyer Pusher Propellers and APC 12x3.8 Slow Flyer Propellers. front and back cw and left and right ccw. Motor-Turnigy 2217 20turn 860kv 22A Outrunner Motor spacing is about 51cm . It does not try to rotate. They arm and disarm fine . One does look more sencitive than the rest but I have calibrated it over and over. Down and to the left to arm?
You need to remove your props and connect your quad up to the configurator.

First, you should be arming by down and to the right. Sounds to me that you need to reverse the rudder servo.

Second, follow this preflight check to make sure everything is in the right direction.
http://aeroquad.com/content.php?118"

JC

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service