It's not a new thing that people can't get the pixhawk to work with emax escs.

If someone has any solution to this problem, please post it here.

If there are no solutions, then could it be possible to make a firmware change to allow stuff people have bought to work?

(Pixhawk won't calibrate the Emax escs on boot)

Views: 9074

Reply to This

Replies to This Discussion


It now obvious that there is a problem on with this Emax 4 in 1 ESC. It seems that it does not work with the Pixhawk. Plenty of people are having this problem.
I am trying to consolidate all the information I found on this problem.

There are other opened posts on the same subject :
Most progress have been done here:

It is very strange since the ESC has the SimonK firmware, and that every other ESC seem to work with the same firmware. It is maybe a modified version.

Anyway, here is my config:
-TX: Frsky Taranis (with latest fw)
-RX: Frsky D8R
-ESC: EMAX 4in1 25Ax4
-Pixhawk FC with GPS (ArduCopter 3.2.1)
-3S 3000 mAh battery

I can indeed calibrate the ESCs when I connect them directly to the radio.
And the Pixhawk doesn't seem to communicate with the ESCs. Somethings happen when I plug some servos to port 5 and 6 (for gimbal), but still, not motor rotation...

I hope this can be solved quickly.
Hello all,

I took the problem the other way. I asked EMAX why it doesn't work. I wrote them an email and here is their answer:

"The current 4 in 1 ESC 25A doesn't support Pixhawk, we had noticed that and are currently modifying the firmware and doing test so that the new firmware will be compatible with Pixhawk flight controller. We will finish test in around a week. I will keep you posted about it."

So, hopefully, we should have some news next week.


Well, finally.

Did you have any luck on this?

Waiting for the solution? :(

Any solution after few months? because i can't do anything... I'm think that i will change my emax 4in1 by qbrain...

To solve this issue with pixhawk and EMAX 30a (only ones I have tried...)

Remove the two resistors marked in the next picture and that will be it!!


Hi Aldo,

Do you say if remove these two resistors, then emax will be compatible with pixhawk?

Do you test it? do you have any video or something?


yes, remove those components, one is a capacitor and the other a resistor... after that, arming/working with pixhawk is doable.

I dont have a video, its really and easy fix.

good luck.

Hi Aldo o Hola,

I opened mu Emax 4in1 of 30A and it's little differents than yours i don't know recognise those components

Here i attach a photo of mine

Can you help me?

It has been frustrating getting my quad to fly with the Pixhawk (from the APM) and now I have hit this Emax ESC problem as well.

I am thinking of

a) removing the (pullup/pulldown?) resistor & capacitor as suggested by Aldo Vargas


b) dead bug wiring a line driver 74HCT244 as suggested by squarepeg

but in case I brick my Emax 25A 4in1 esc and I have to buy new ones, I was wondering how we can tell if an esc supports Pixhawk pwm at 3.3v?

Does anyone know which esc's definitely work with the Pixhawk and wont glitch?

maybe is easier if you contact EMAX support... they might know exactly which ones to remove, with the single one is easier, this one is a bit more complex...

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service