hello everyone!

I just received my ArduPilot 2.6, everything is fine but ...

I be trying to operate the camera gimbal servos. I followed the guide copter.ardupilot.com page does not work.

I connect the tilt servo to rc10 and I set it up in MP. in RC10 just connect the cable from the servo signal, and connect the + and - output 7.

look at the pictures, I need to connect the servo to an external source?

servo model is the micro servo 9g

 

 

 

Views: 6994

Reply to This

Replies to This Discussion

Same problem. All hooked up and it doesn't work. 

OK this is what I have done to power the gimbal servos.  APM 2.5 powered by the 3d Power Module Jumper removed.  Signal wires for pan and tilt  to A9 and A10. positive and negative wires from pan and tilt servos to positive and negative OUTPUT rail. Gimbal Did not work.  Removed leads from output rail and connected to separate 4.8 volt NiMh pack.  Servos work but not controlled by APM 2.5 probably as there was not common negative .  Plugged signal positive and negative into output rail number 5 and 6, servos can be controlled by TX.  Plugged signal wires into A9 and A10 and pos and neg into Y lead plugged into Input number 8, Nothing.  I despair and give up.  I have taken FPV kit off the quad and bought a Skywalker 1680 V6 with a camera stab system from HK.  Worked first time.  I tried to follow the Wicki regarding wiring the APM 2.5 for a gimbal but there  is too much jargon, when will these guys realise that not everyone has a degree in advanced electronics?  All you need is a "plug this lead into this socket" text with a simple diagram.  Perhaps that's how they get their kicks?  

You dont need a common ground to hookup a servo signal. Its quite common to connect the power(+ve) and ground(-ve) to something and then hookup the signal by itself.

I will agree however that the 3DR wiki should show simple diagrams as the wordy text can seem to be ambiguous while a picture is always much clearer.

I do have a degree in electronics. It still doesn't work. I don't have access to o'scopes or anything any more, just a multimeter.

Will probaby get this sorted today.... But the "correct" way doesn't work for sure.

Bill check this image
http://storage.ning.com/topology/rest/1.0/file/get/33668206?profile...

i take the + and - from the power distribution board. try frist whits a simgle ESC anda baterry

Luis that's the same as putting a separate 4.8 pack on the servo, as I did, and it still did not work

not the same thing! try it as I say and everything works fine. need the power of the esc.

Yea, that's EXACTLY how I have mine.

No worky.

Connected a servo directly to A10, that doesn't work either. Were gimbals broke in 2.9.1?

Found it. I updated Mission planner, then had to go fix the channel to A10 (RC10) and it works now. Apparently the old mission planner was writing out the wrong channel value. 

THANK YOU! this has been driving me nuts all night. The APM instructions are vague at best and all this crap about output terminals was confusing.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service