Having issues with consistently getting Aero/Pxhk to spin the motor up to full speed when set to Auto and a mission loaded. I have basically set TKOFF_THR_MINACC and TKOFF_THR_MINSPD to 0(zero). Sometimes the motor will spin up with a quick forward throw, and then go to manual to shut it down, switch to Auto and go again with a quick forward throw and the motor does not spin up.

The reason for setting above value to 0 was to eliminate any minimal checks. Previous values were set to 3 and 1 respectively and NO and same results, intermittent motor spin up.

WTF am I missing here or have set up incorrectly?

TIA!

Views: 738

Reply to This

Replies to This Discussion

It should spin up without a throw with those values. I think your problem is elsewhere.

TKOFF_THR_SLEW: 50 
TKOFF_ROTATE_SPD: 
TKOFF_THR_MINSPD: 
TKOFF_THR_MINACC: 
TKOFF_THR_DELAY: 

These are my settings. It will start instantly, but the TKOFF_THR_SLEW value will make it do so fairly gently,. giving me a chance to get set.
Delay value is irrelevant as the MINSPEED and MINACC = 0.

I have :

ARMING_CHECK = 0

ARMING_DIS_RUD = 0

ARMING_REQUIRE: 64 (RC failsafe only...really should set it to 72 for field work)

BRD_SAFETY_ENABLE=1

What if you reduce the values so that you can arm it by doing fake throws? Take the prop off first, obviously :).
Might be one way of testing it, without bungeeing it into the ground everytime.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service