Current Features:
Parsing for NMEA, SiRF, uBlox, MediaTek, ArduIMU Binary and AP ACSII
Record/Playback for raw datastream
Working avionics instruments
3D rendering of EasyStar, FunJet, Quad and a few other models
Google Earth and Google Maps real-time (non-KML) disply
Live video stream
Himan readable serial data stream (including binary)
Windows only

Still to come:
APM 2-way communication and configuration including in flight waypoint editing
Auto download of waypoint data for AP
Language translation file
X-Bee uploading of compiled source
Resizing and possibly drag and drop of components
Save video stream
KML file support

http://code.google.com/p/happykillmore-gcs/downloads/list

Views: 7321

Reply to This

Replies to This Discussion

Absolutely. I know exactly what's going on. The ArduPilot, ArduIMU and APM protocols all are missing data. They have no variable for GPS lock, nor satellite count, nor HDOP, nor GPS time. It also depends upon the version of the MediaTek you're using. If you flashed it with 1.6 then I can't say for sure that the GPS parsing is working 100% on the APM yet. I would take a look at the serial data coming across in the Serial Data window.

 

Drift of lat and long is not a function of my GPS...I just display what I'm getting. Knowing how many sats you're connected to would be very helpful...but at the moment they are not included in any ArduPilot data stream to the best of my knowledge. The bigger issue is the lack of GPS data coming out of the telemetry port when there is no GPS lock. I am lobbying for a fundamental change in the way this works as any loss of GPS lock will mean the GCS user is in the dark.

We're on it. Missing data fields will be available in the next version of the APM and MTK code.

If you want the number of satellites now add the following to GSC_Ardupilot tab then under the void print_position

SendSer(",SAT:");
SendSer((int)GPS.num_sats);

I add it just before the following line
SendSerln(",***");

 

Working on Fix at the moment

I've got this program working with my Ardupilot with the exception of the battery voltage. It reads over 100,000 volts. Voltage reads fine with the original Ardupilot GCS. Is this a setup/configuration problem?

 

Thanks!

 

John

There must have been a change to the ArduPilot GCS output at some point. Are you using the "Legacy" output? Where it's !!!LAT:XXXXX, etc or are you using a binary output?

 

If it's legacy, take a look at the output .pde file (it's been renamed several times) and look at the BTV: output. Make sure it's sending a non-scaled value. So 12.41 = 12.41. You might have something *1000 so the output is scaled way up.

I just checked and there is no scaling factor. However it does appear that if I divide by 1000 the voltage showing up in the GCS may be correct.
Give that a try. Oiriginally I had been multiplying by 1000 which would have worked fine for you...but I was told by another AP user that it was off by a factor of 1000 so I removed that.... So something must have changed at some point in the legacy protocol.
Okay, I'll do that. Thanks for the help. Fantastic program BTW!

Happy,

I just tried to load a waypoint file into the latest version and got this error:

 

I got the same error with v 1.2.10.

I can email you the whole error message if you need it.

 

The GCS just gets better and better!

Irvin, please email it to happy@happykillmore.com

 

I'm planning on re-vamping the mission load/save function. I just edited the code to get by for now...my plan is to make a universal file format that I can use on my GCS to load and save in just my GCS or output in a file type for a specific auto pilot..

Happy, could I just ask what data is used for the heading display ? the one were the compass rotates around a fixed arrow.
Depends upong the input source. It's "heading" not "bearing" or "yaw"... The data comes from the GPS for this indicator.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service