Okay, let's outline what I have; What's happening; What I've done to try and fix it --

What I Have:

I have an H-Quad I just built.  I installed the APM 2.5+ with the uBlox LEA-6H GPS module.  There is no telemetry or other sensors attached at this time.  It's connected to an AR6200 Receiver, and four Hobby King Plush 30 Amp ESC's and then to cheapo HK motors.  I'm using a JR 9303 DSM2 radio. The Battery is a 3S2200 for now (just for testing and motor spin up).  I've downloaded and installed MissionPlanner-1.2.36.msi without issue.  The drivers install fine, and it loads fine.  My primary rig for this set up is a Windows 7 64-bit machine (Intel i7-2600K with 16GB of RAM, and an Nvidia 670 graphics card...for what it's worth).

What's Happening:

Last night I hooked up the APM 2.5+ via USB and was going through the setup of the board.  It downloaded and installed the ArduCopter V2.9.1 Quad firmware successfully.  I then clicked on Connect (after selecting Com11 -- where the APM 2.5+ was configured), and proceeded to the APM Setup (Plane and Quad) section (button at the bottom of the Firmware page).  I went through the Radio Calibration and reversed those channels needing reversing.  All good.  I click on the assignments for the switches, and as I'm going through the options...it disconnects.  Period.  Never to reconnect again.

What I've done to try and fix it:

Okay...something is up.  So...I power everything down...and power everything up.  No good.  Doesn't connect (Mission Planner doesn't list COM 11 nor the Arduino anymore in the pull down menu) and Windows no longer has the "Arduino Mega 2560 (COM11)" listed under the device manager.  I then go through the a re-install of the Mission Planner software and select "Repair" and reboot.  Doesn't fix it.  I force delete the "Unknown" USB device and reboot and reconnect.  Same problem -- Unknown device.  I read on the forums about bad cables...change that. Nope.  

Thinking I have a corrupt install, I uninstall the app. Restore a Registry Backup from before the original Install, reboot, re-install, reboot,and re-connect.  Nope.  Thinking that the drivers may be embedded under the System32 folder, and rather than dig it out manurally....I try another Windows 7 machine. Nope. I try a Windows XP machine. Nope.  I try a Mac with Windows 7 on it via BootCamp. Nope. I try a Windows 7 VM under Linux using VirtualBox. Nope. I try Windows 7 under VM Workstation under both Linux and Windows...Nope.

Okay...So at this point, I try to connect the battery to the APM 2.5+ and then hook up the USB cable.  Bingo!  Now the "Arduino Mega 2560 (COM11)" shows back up under the Device Manager, and is listed under the pull down on the Mission Planner" software. **NOTE TO OTHERS HAVING CONNECTION ISSUES:  Try connecting the battery to the APM before connecting to the PC and see if that fixes it."

Okay, so now that I see the controller, I try to go back in and re-load the Quad firmware...I get an error (see screenshot), but here's a handwritten copy of what it said --


Failed to download new firmware: System.IO.IOException: A device attached to the system if not functioning.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream.EndWrite(IAsyncResult asyncResult)
at System.IO.Ports.SerialStream.Write(Byte array, Int32 offset, Int32 count, Int32 timeout)
at System.IO.Ports.SerialPort.Write(Byte buffer, Int32 offset, Int32 count)
at ArdupilotMega.Arduino.ArduinoDetect.DetectBoard(String port) in C:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Arduino\ArduinoDetect.cs:line 126
at ArdupilotMega.CGSViews.Firmware.update(software temp) in C:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Arduino\CGSViews\Firmware.cs.line 366


Okay...this is a problem.

So...I then try to skip the Firmware download and hit <CONNECT>...I get another error (See screen shot)....but it basically says "Access to the port 'COM11' is denied"....blah blah..and points to a bunch of code lines.  Again, see screen shot for more details.

So...now what?  I'm out of ideas, and I'm frustrated.  I'm about to send this thing back for an RMA, as I have enough headache in my life without this thing adding to it.

Thanks in advance for the help!!



Views: 5487


Reply to This

Replies to This Discussion

Just for completeness sake, thinking that I may have bad code on my Primary Windows Machine, I attached the APM 2.5+ to another Windows 7 machine after I discovered the necessity of having the battery connected.  The device did show up on the Device Manager, but when trying to connect via the Mission Planner software...I get the *EXACT* same error when trying to push the Quad Firmware to the APM, and it simply times out when hitting <CONNECT>.

As I think on this, I'm thinking the APM is damaged.  Something caused it to disconnect during the configuration, which may have left the firmware incomplete, and inoperable. I may have to RMA it after all. 




If it helps there's a thread here that has a solution to a similar problem but requires replacing a 3.3V regulator.

You may be close to the mark...in one respect.  

As I think on it, I think the Firmware on the APM 2.5+ became corrupt when it disconnected itself from my computer during configuration. I suspect the reason for the disconnect may be tied to a component failure in the power circuitry.  Given the fact that it is no longer recognized by my PC unless the battery is hooked up, makes me believe an electrical component failed. It simply isn't getting enough power through the USB bus anymore.  When the power glitched/failed, it cascaded into corrupting the Firmware on the board.


As I continue to troubleshoot...I hit the RESET button on the controller (thinking it may clear the Firmware)...now it's refusing to connect as far as it had.  Now COM11 is is offline and the status shows it as "This device cannot start. (Code 10)"  See Screenshot.

My problem is different, I can upload firmware, but connect fails and the gyro won't boot. So sorry can't offer much advice on your issue. Can you do an erase/reset in the terminal tab?

Tried...but until it connects, it won't talk to the terminal.  As I continue to dig...I'm getting denial of access to the USB port on the APM.  I put in for an RMA...I think it's a hardware issue at this point.  Unless someone can point me toward something else that works...I'll keep listening and trying.

Thanks for the input!

I'm having the exact same problem!!  I can successfully upload the 2.9.1. firmware but I cannot connect Mavlink. I've tried all of the "tricks" you listed (i..e. battery first then usb etc.) nothing helps.  I sure wish someone from the dev team would respond on this one.. I'm sitting here with a beautiful 2.5+ APM that's totally useless.

Hi Tom,

Have you already solved your problem with Mavlink connection? Using BT module; 3DR or just usb?

Yes !!  Thanks for the followup though ---- I appreciate it :-)

Hi tom,

how have u solved? I'm experiencing same problem with Windows 7 Pro and all my ardupilot boards (VR Brain 5.2, VR micro Brain 5.2 and PX4 clone)

Tom Evans said:

Yes !!  Thanks for the followup though ---- I appreciate it :-)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service