Help! MediaTek Problems

Comm problems seem to be drawn to me.  This time it appears to be an issue with comm between the GPS and the APM.  I reliably get a solid blue light on the MediaTek, indicating GPS lock I believe, but the red LED (C) on the APM doesn't light up.  I'm running the ArduPiratesNG release 458 (latest one available for download on their wiki).  Best I can tell, there's no way to know what firmware is loaded on the GPS, but I see the same behavior if I configure for 1.4 or 1.6.

 

My first thought was that it's a GPS firmware problem and I need to reload the firmware as instructed on the wiki (gotta buy a friggin' FTDI cable, ARGH).  But then I saw this post, which led me to believe that there might be some versions of the code floating around where LED C isn't functioning correctly???

 

I've also read multiple insinuations that there's some way to test the GPS via CLI, but I can't find instructions on how to do so for the life of me.  Then I found this post on RCG and ran knuckles' code, whose result was a bunch of gibberish on the serial monitor.  Here's a sample:

 

Ö f¡ÎÐÝ âá´ûùz_M × ~±§ÐÝ âá´ûùz_M Ø ©"ÐÝ âß´ûùz_M Ù ~¢ÝÐÝ âß´ûùz_M Ú ÐÝ âß´ûùz_M Û ÐÝ âß´ûùz_M zÜ fz<ÐÝ âÞ´ûùz_M tÝ fuÐÝ âÞ´ûùz_M nÞ fq

 

And as a longshot, per this post, I've hit the reset button after getting a lock while configured for both 1.4 and 1.6 ... with no luck.

 

Any ideas?

 

... I think my head is going to explode :) ...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am having a similar issue.....facts

    1.bought MT3329 smt module from diydrones last week

    2.I put it on the board and used sparkfun level shifter to connect to arduino pins, and left enable floating.

    3.apply 3.3volts and light blinks...it has been blinking for about 8 hours now....no lock

    3.when I try to run test code from link on product page, it does not work....It was not designed for 2560 board so I changed the if defs to allow it, and it still locks up after "GPS MTK library test"

     

    4. So then I tired serial pass through example in arduino ide.....I get a bunch of binary characters like shown above

     

    4.I ran the pde that is attached in this post and I got the following output.

    Setting to NMEA modeSetting to real slow modeRequesting relase numberRequesting relase number<10><FFFFFFEC><FFFFFF90><FFFFFF92><FFFFFF90><FFFFFF90><FFFFFF80>p<C><C><C>l<FFFFFF8F><1C><FFFFFFE0><FFFFFF8C>b<C><FFFFFF8F><FFFFFF93><C>bcbbc<C>b<C>ccb<FFFFFF8E>p<C>c<FFFFFF8E>p<C>b<12><FFFFFF90><FFFFFFEC><FFFFFF8E><E>l<10><FFFFFFEC><FFFFFF90><FFFFFF92><FFFFFF90>l<2><FFFFFF82>b<FFFFFF80>p<FFFFFFFC>pp<C>bbbcbbccbbccb<FFFFFFE2>lll<FFFFFF90><E>l<10><FFFFFFEC><FFFFFF90><12>lsr<FFFFFF83>c<C><C>l<FFFFFF8E><FFFFFF8E><C><FFFFFF8C>b<C><FFFFFF8F>sp<FFFFFF8C><FFFFFF93>ccbbc<FFFFFF8C>b<FFFFFFFC><FFFFFF80><C>c<FFFFFF8C>b<C><C>c<FFFFFF8C><FFFFFF8F>l<C><C><C>cRequesting relase numberRequesting relase number<10><FFFFFFEC><FFFFFF90><FFFFFF93><FFFFFF90><FFFFFF90><FFFFFF80>p<C><C><C>l<FFFFFF8E><1C><FFFFFFE3><FFFFFF8C>c<C><FFFFFF8E><FFFFFF93><C>bcbbc<C>b<C>cRequesting relase numbercb<FFFFFF8E>p<C>c<FFFFFF8E>p<C>c<12><FFFFFF90><FFFFFF8C><FFFFFF8F><E>l<10><FFFFFFEC><FFFFFF90><FFFFFF92><FFFFFF90>l<3><FFFFFF83>c<FFFFFF80>p<FFFFFFFC><FFFFFF82><C>bbccbbccbbccbb<FFFFFFE3>lll<FFFFFF90><E>l<10><FFFFFFEC><FFFFFF90><FFFFFF92><FFFFFF90>l<FFFFFF9C><FFFFFF82>bppl<C><FFFFFFE2><FFFFFF80><C><FFFFFF8C>c<FFFFFF8E>|rl<10><FFFFFFEC><FFFFFF90><12>lrr<FFFFFF83>c<C><FFFFFFFC><FFFFFF80>l<FFFFFF8E><1C><FFFFFFE2><FFFFFF8C>b<C><FFFFFF8F>sp<FFFFFF8C><FFFFFF93>ccbbc<FFFFFFFC>|<C><C><C>c<FFFFFF8C>b<C><C>c<FFFFFF8C><FFFFFF8F>l<C><C><C><FFFFFFE3>p<C>cl<12><FFFFFF90><FFFFFFEC>Requesting relase numberRequesting relase number<10><FFFFFFEC><FFFFFF90><FFFFFF93><FFFFFF90><FFFFFF90><FFFFFF80>p<C><C><C>l<FFFFFF8E><FFFFFF8E><FFFFFF8C>c<C><FFFFFF8F><FFFFFF92><C>bbcbb<C>c<C>bbc<FFFFFF8F>p<C>b<FFFFFF8F>p<C>b<13><FFFFFF90><C>l`<2><10><FFFFFFEC><FFFFFF90><FFFFFF93><FFFFFF90>l<2><FFFFFF82>b<FFFFFF80>p<FFFFFFFC>pp<C>bbbcbbccbbccb<FFFFFFE2>lll<FFFFFF90><E>l<10><FFFFFFEC><FFFFFF90><12>lsr<FFFFFF83>c<C><C>l<FFFFFF8E><FFFFFF90><C><FFFFFF8C>b<C><FFFFFF8F>sp<FFFFFF8C><FFFFFF93>ccbbc<FFFFFF8C>b<FFFFFFFC><FFFFFF80><C>c<FFFFFF8C>b<C><C>b<FFFFFF8C><FFFFFF8F>l<C><C><C>cbRequesting relase number

     

     

    I am thinking the level shifter might not be working properly or something. But I don't know why it has not gotten a gps lock yet. Any help is appreciated thanks!

  • I am running the RC2 coding for my Quad.

     

    I have the Solid blue led on the mediatek GPS but the Red led on APM will be kept blinking. Does it meant the APM didnt recognise the GPS lock from GPS?

  • Thanks for the gps - test - code:

     

     

    It doesn't work:

     

    3692164767?profile=original

     

    I guess this means my gps doesn't work.

  • I typed test, but cli only recognized the t and startet "calibrate min throttle value"
  • Yes,
    I am.

    What setting in the cli do I need to choose so I see the gps status?
  • Hey Martint,

    you mean the baud rate while in cli: max   I guess 115000   I can't look right now.

     

    I don't have a ftdi cable yet, so I can't check the gps

     

    I used the online configurator to setup gps to v1.6  (in hope this one is up to date)

     

  • I got it from Fahpah.com:

     

    Here are some pictures: 

     

     

    3692164538?profile=original

     

     

     

    3692164610?profile=original

     

    http://Fahpah.com/
  • NO,

    I don't think so.

     

    At first I tried to build my own FTDI cable and the first thing I did was connecting +5V and GND to the module and the solid blue led went on.

     

    (+5V was written on the module)

     

     

    ...please don't tell me I've killed my gps

  • I don't think the solid blue led of the mediatek gps module is a sign for gps lock.

     

    As soon as I switch on my copter the blue led is solid blue. And I am inside...never went outside, yet.

  • @Ariley

    re. I reliably get a solid blue light on the MediaTek, indicating GPS lock I believe

    Correct.

     

    re. Best I can tell, there's no way to know what firmware is loaded on the GPS

    Incorrect.

     

    Read this thread, all the way to at least page 3. (Today) I show a method to query the GPS.

    http://www.diydrones.com/forum/topics/mediatek-gps-up-to-date

     

    re. ran knuckles' code, whose result was a bunch of gibberish on the serial monitor.  Here's a sample:

    Ö f¡ÎÐÝ âá´ûùz_M × ~±§ÐÝ â

     

    The GPS may be in binary mode. Or the baud rate on your computer may be wrong. Or the cable could be Borked. Or when programming of the APM you may have selected a board with a different clock rate, so the baude rate of the APM isn't what it is supposed to be.

     

    If the CLI doesn't communicate with you, upload to the APM a simple "Hello World" sketch to see if you can Serial.print() back to your computer or if that is messed up.

     

     

     

     

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…