After a minor crash I've fixed my hexa copter but in MAVLink under flight data, in the status tab, roll, pitch, and especially yaw are changing wildly. The horizon in the flight hud jumps all over, including upside down!.  I have downloaded new firmware, recalibrated the transmitter, calibrated the compass, leveled the hexacopter and it still does the same thing. Also, it doesn't really seem to respond to movement either, or the values change so rapidly that I can not see the changes for movement. My APM 2.5 is wired correctly according to the recent post on connections. I'm not sure where to go from here. Is my APM trashed? Oh, i've tried monitoring with both 3DR radio and USB connections, too.





Views: 839

Reply to This

Replies to This Discussion

How do I run a test from a .pde file? Sorry for now knowing the "basics" yet.

I do firmware development so I'm sure I can figure out the GUI. I ran the terminal setup / level command and it says gyro did not converge, diff=1.123 (various values). It seems a hard knock must have damaged the gyros. I check the board under a microscope and didn;t see any obvious damage but I'm buying a new board anyway. And yes, it was a 3DR board and the new one will be also.

You might want to give this a shot. Use the CLI to reset and erase the eeprom and reload the firmware.

I had the same problem of my new quad APM2.5 crashing causing the gyros and magnetometer go out of whack, same thing no physical damage though I suspect the heavy G forces during the crash caused something weird to happen. My dealer Yovi, helped by erasing eeprom and reloading the firmware and that fixed the board. He also advised me that if I want to update my firmware, it is a good idea to erase the eeprom before doing it.

Hope this works for you! Cheers!

I'll give it a try. Roll and pitch are working correctly now but yaw when graphed looks like a heart monitor! I don't think the hardware is really at fault. It looks like the PID loop eliminates error a little at a time, until it gets close to 0 then spikes up again all at once. I'll post a graph later tonight.

the reset and reprogram didn't work. I have a new board on order. It has to be hardware. Altitude is also pretty unsteady with the hexa sitting still.

Just curious, did you try the reset button on the board? You might want to try the erase eeprom command again and try a re-calibration.

I tried everything, and got nowhere. My new board should arrive today so I can compare resutls. It's just really weird yaw would change so much, so fast, with the hexa sitting on my pool table.

It was the board. Roll, Pitch, and yaw all stay nice and steady now, as well as altitude.

HI David, I rushed to conclusions. I think I have the exact same problem as you. I thought the erase eeprom command work but apparently the sensors will work for the 1st minute before going sluggish. I suspect this was what caused my 1st crash. My replacement board is free from these issues.

I updated the board to the latest firmware 2.9 and all seems well for the 1st minute and then the sensors just went sluggish and non responsive. I'm sending it back for my dealer to take a close look and possibly ship back to 3DR for analysis to see if this is a QC problem.

Im having the same sort of issue, but this APM 2.5 is yet to actually fly, its brand new fitted to the air frame. Calibrated everything, yet the hud jumps all over the place sat on the desk. 

When i first installed the firmware it was sat on the desk and the hud was fine. That was 2.8.1 I think, now it has 2.9 on it.

Guessing its not a good idea to fly it like this. 

All I got was a hard flip on takeoff. I got a new board and my arducopter flies very nicely now. I didn't send the board in because I crashed the heli, but now I might it it's a common issue.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service