Hello. I have assembled an arducopter. The specifications are given below.

jdrones default frame (with foams attached under arms)

Configuration: Quad X

APM 2.0

880 Kv Motors

12x45 propellors

Futaba 10CHG

The frame was assembled as per the wiki. The ESCs have been calibrated as per the wiki. Props were attached properly and balanced. The accelorometer calibration were also carried out as per the wiki.

The modification that was carried out was just the attachment of foams under arms. Since i was new to the flying, so i wanted to save the arducopter from crashes which i experienced initially. The 4 foams have a total weight of 126 grams.

The pid parameters were adjusted to counter for the heavy motors and sensitive controls. Rate_p and Stab_p were changed. The parameters file is attached.


The arducopter has a tendency to move away from its position after take off. I only alter the throttle input and after it rises to some height it moves away from the point from where it was taken off. May be wind should be considered but that was not enough to move it from the center of a football size ground to almost its end in stabillize mode.

The arducopter also has a tendency to lose altitude sometimes. After it has been taken to a certain height in stabilize mode, the copter loses altitude without any throttle. Though it should have been put in ALT HOLD mode for this purpose, but even in stabillize mode it should not lose altitude of 6-10 meters. Once i took it to about 10m, it was in stabilize mode and after some time it started losing altitude to an extent that when it was about to land i cut the throttle and made it land.

Another major problem that i am experiencing is that it flips over without any other input other than throttle. It happened once in ALT HOLD mode (crash 1, video and tlog file attached below) and two times in stabilze mode (crash 2 and 3, video for both and tlog file for crash 3 attached below.)

crash 1 - 2012-12-11%2010-49-59.tlog

Arducopter crash 1 - Flipover Video from Majid Khan on Vimeo.

Sorry. Don't have a log file for crash 2

Arducopter crash 2 - Flipover Video from Majid Khan on Vimeo.

crash 3 - 2012-12-11%2014-13-20.tlog

Arducopter crash 3 - Flipover Video from Majid Khan on Vimeo.

Views: 1517

Reply to This

Replies to This Discussion

Hi Majid,

I've been having sudden flipovers too.

The first time was in stabilize mode.

The second time was in LOITER mode, and I got video and log of the second crash.

Video here: http://www.youtube.com/watch?v=pHqjheOdlbs

May I know if you have anything attached to CH6 of the APM2?

I have my DX7's transmitter's (2-position gear switch) ch5 inputting ti CH6 of APM2. If the input is high, I get random quick twitches every 3 to 10 seconds, if the input is low, the quick twitches do not happen, but now I have this sudden falling out of the sky problem. When I repair, I would be trying with nothing connected to APM2's CH6.


My logs showed that correct countering commands to the motors were given. If the signals were indeed sent to the ESCs then maybe my ESC and motors are to blame, I guess I can swap in a different flight controller to be sure. I have a brand new Hobbyking KK2.0 to test out.

My quad-X in the video has yellow props up front, and red props on the back, and the quad was oriented facing away from the camera. In my flipover, the low arm was the rear-left one, i.e. motor #2.

The graph below does show servo2 (blue) go up, and servo1 (bright green) go down, so this looks correct right?

After seeing your video, I have had 2 similar instances.

One was after 3 auto flights, on the 4th between the 3rd and 4th waypoint my copter flipped just like that.

The second time was when I was using ground station to change modes from loiter to stab. I clicked the button to go to stab on GC (flight stick was neurtal) and the copter just fliped.

The 1st flip was exactly like your video.

The 2nd flip was like it was powering through an actual flip maneuver.

Havent been through the logs yet tho.

me too had the same crashes, and today when i was trying to tune my arducopter by holding it in my hand to get a feel of the parameters i changed, i got the reason of my crashes. One of my motors stopped for no reason!!

this was not something that i expected but, it was in my hand i gave it some throttle tried different controls. gave some disturbance inputs by moving my hand and all of a sudden one of my motors stopped. i repeated this thing several times and sooner or later and some times much later the same motor used to stop. 

now i know my Quad crashed because of motor stopping in flight BUT i don't know why the motor stops!!!

is there something wrong with ESC or motor or what, idon't know. 

After getting similar symptoms when I replaced the APM2 with KK2 and also during a bench-test without any FC (just a 1-to-4 servo wiring), I am convinced that my problem isn't the APM2.

I suspect it is ESC/motor-overheating. 

Bench-test also revealed resonance vibrations with my sloppily assembled US$40 quad frame from OMGFLY.

Try a smaller propeller, perhaps 11inch, to help rule out motor stall.

Hi Majid,

I'm having a similar problem and am trying to get to the bottom of it by comparing your configuration with mine.

BTW, I admire the foam cushion design.

Can you share a little more of your thinking on why you reduced the RATE_PIT_P from the "stock" setting of .17 to .1 ?  

I wonder what you mean by "heavy motors and sensitive controls" because the specs on your motors and props look fairly standard.

I'm thinking (admittedly without full understanding) that when RATE_PIT_P is reduced without reducing RATE_PIT_I, the emphasis on the historical error increases.

(Unlike your situation, my flips have been occurring after making several sharp turns.  To eliminate hardware as a factor, I'm replacing my APM, ESCs, and motors.)


I should add that I've been flying ArduPilot aircraft (multi-rotors and planes) for about three years now and this is the first time I've encountered this problem.  Because of this, I'm more than a little inclined to think it's an motor/esc/wiring failure.  On the other hand, I've been flying RC for years and have never seen those components fail sporadically in this way either.

as i mentioned earlier in this discussion that i was having the same problem, i was also trying to find out the reasons. I guess I've found one.
I was using the BEC of my ESC as all people usually do, but recently when i was studying about different things here and there on forums  i came to know that the ESCs i am using have linear BECs and Linear BECs waste a lot of power. there is another type called switch-mode BEC which is much more power efficent. as justgofly.com says and i quote:

"Comparing a linear BEC with this switch-mode BEC: When using a lithium battery pack of more than 3s (11.1 volts), a switch-mode BEC has much higher efficiency than the linear BEC in your ESC. A linear BEC on a 4s lithium battery pack has a typical voltage of 14.8V, in order to change a BEC outputs 5V/ 1A , the current flow into BEC is at least 1A , so the power on BEC is 14.8V* 1A =14.8W. But the useful output power is only 5V* 1A =5W, so the efficiency of BEC is 5W/14.8W=33.8%, the redundant power 14.8W-5W=9.8W changes to heat, which makes the BEC very hot. But a switch-mode BEC with the same 14.8 volt battery in providing 5Volts 1 amp drops the current flow into the BEC to 0.38A (actual test data), so the power on BEC is 14.8V* 0.38V=5.6W, and the efficiency of BEC is 5W/5.6W=89.3%."

so now i guess the one motor that was stopping was because of the ESC becoming too hot and inefficient and under nearly low battery conditions when all other ESCs were still on and running this one used to stop. 

all other motors and props are same. and only this motor stops. I've interchanged the props nothing happened. If the motors were to stall any motor would randomly stall, but this is not the case here, every time the same motor stops. i would have tried the 11 inch props too to see what happens but i don't have those :(

I am also suspecting the BECs are the problem.  Here's my reasoning:

RedPalm's log does seem to show the ArduPilot was giving the right signals.  Unless the motor failed, the BEC cutting the power to the motor is the most likely cause for the motor stopping.  I said above that in many years of RC flying, I had not seen random motor cuts.  I thought more and recalled that once or twice I have seen BECs cut motors even when there was adequate power.  With planes, you can usually land safely.  With quads, no such luck.

I also thought of something else.  I have never had this problem with my stock 3DR hexacopter.  It uses the 3DR power distribution board which only sends the control (PWM) wire to the ArduPilot.  Does this effectively disable the BECs?

I'm having this problem on my custom quad-copter where the ESCs are plugged directly into the ArduPilot, leaving the BECs enabled.  With a quadcopter, there is no situation where you want the BECs to cut power to the motors.  So, I'm going to disconnect the center wire on the ESCs servo connection and test.

I'm not completely sold on this solution.  These failures are occuring when the battery voltage is more than adequate, so if the circuit were working correctly, it shouldn't cut power.  But, circling back to the beginning, I think the BEC incorrectly cutting power to the motor is the most likely cause.

After testing and re-examining the 3DR PDB wiring...

In hindsight it's obvious...  at least one of the red (middle, power) wires from the BEC needs to remain connected to power the ArduPilot.  This is how the 3DR PDB are designed, using the number 4 motor's ESC/BEC.

Alternatively, you could use a separate BEC, attach it to the RC Receiver, and change the jumper setting on the ArduPilot that controls whether the power comes from the input (Rx) or output (ESC/BEC).

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service