Help, please, with RFD900a radio that appears to be bricked

Hi folks,

One of my RFD900 radios was working fine for months but is now only showing 1 solid red LED. Using USB/FTDI, I'm unable to connect or reset it with MissionPlanner ("No heartbeat packets received") or with the 3DRRadio.exe ("Failed to enter command mode") config tool.

I've tried all the baud rates and even tried different USB ports. The other RFD900 connects just fine using the same USB/FTDI connection. 

Any suggestions on how to troubleshoot this? Or how to reset the device? 

Thanks in advance!

Phil

Views: 566

Reply to This

Replies to This Discussion

Here's a follow-up posting with the fix, in case others face this same issue.

The simple fix that worked was to run the 3DRRadio.exe tool and click the "Upload Firmware (Local)" button. This successfully connected to the RFD900a and reloaded the firmware. The radio LEDs are now working normally (green LED blinking) and I'm able to connect, "Load Settings", "Save Settings", etc.

Solid red means firmware update mode.

One more piece info to help anyone else that cannot connect to the radio for reprogramming. Page 4 of the "RFD900 radio modem software manual" says: 

"In case there is need to force the modem into boot mode, short circuit" the pins "labelled CTS and GND..."

I just tried this successfully and was able to connect and reprogram the radio. 

Thanks, Marcin.

Thanks. It's helpful to have all this information together in one thread. 

Here's a link to the "RFD900 radio model software" manual mentioned above.

http://rfdesign.com.au/downloads/Software%20manual.pdf

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service