Hi. - Happy new year.

Im new to copters but have been using arduplane for a while.


I have been setting up a new quadcopter and following Dave Cs guide. Its flying very nicely in all modes and I have done a few auto missions around my field.

Before the problem flight I had done exactly the same Flight Plan (route and heights) except at speed 2m/s.

For the second flight I set 6m/s and a halfway waypoint with speed change to 10/m/s. On the way back there was another speed change down to 2 m/s.

Height keeping on this last flight was not great but on the way back it just went into full climb reaching 227m before I rescued it. The green height bar on the flight data display is defiantly below.

It is not an error in the flight plan and the alt-error feed shows an increasing error.


I just cant see why it did this.

Any help appreciated. Logs attached.



Views: 803


Reply to This

Replies to This Discussion

By the way, Im not trying to get anything remotely exciting or twitchy. I will fly something different for thrills. I just want a dead stable machine for auto missions. Once tuned I probably wont use acro much.

If my sluggish yaw is normal thats fine.

Still also worried about the copter doing a rocket impression again as Ive only changed pitch/roll rates since then and I dont think that caused it.

Also, when I tried the more 'normal' parameters this morning loiter just didnt work at all, just like it was still in SATB.

Hey all:

I too had a "fly away" or at least a fly up with my hexacopter.

I have a quad APM2.0, and it has been pretty stable.  I wanted a copter that could lift a camera with a gimbal setup. Yes its too snowy to go to our regular field. I just wanted to test the motors never expected this...

I loaded the latest version 1.2.28 on my APM 2.5.  The tlogs and KMZ file show about a ceiling of 1000ft. My fail-safe I thought was set, I'm still in a little shock. I only programmed two flight modes, stabilize and Alt-hold.  I know, next time it will be tethered, I promise! It seemed I had control of the pitch, yaw and roll but no throttle. I will attach the tlog, I also had a gopro on-board to help with the data[ Hexacopter].  I will look at some of the feedback answers to the problem above, to see if there is any correlation. I saw the talk about dampening the sensor on the APM board because its open to the turbulent air. After the replacements parts come in, I will try that. 


This happened to me once with a different multi rotor.

I'm not saying I think this is what happened with you, but I will share this episode that happened to me. 

When I go my Quadcopter, On my JR9303 radio, I initialized a new model memory slot to program my copter (when I first set it up). I chose a new unused memory and it was already set to Acro.

I proceeded to do all the calibrations etc. I took it outside for the maiden flight, took off in manual and landed and all was fine. Then I switched to stabile and took off. I was dismayed to see it climb and was unstoppable. even with the throttle at the bottom, it still continued to climb straight up. It was a mere dot in the sky within a couple of minutes.

It was a fly away, and nothing feels worse than seeing it go bye bye!

It was probably over 500 feet up then I managed to break it out somehow, (still not sure how) and it came down, tumbling with the motors off!.

It was falling extremely fast and I gave it full throttle at about 150-200 feet and the motors started and it stabilized, the decent nearly stopped entirely but fortunately the the downward momentum was just enough that it hit the top of a tree, broke a prop and finished its fall to the ground. (within twenty feet if where it took off from, at least the GPS was working.  It broke two props and broke two arms. Later I found that it also damaged the GPS.  IF it hadn't hit the tree, it would have began its climb again!

Afterwards I found out the problem with my setup.  Always reset the model memory you are going to use in a JR9303. I found a mix was enabled: there was an auto-landing configuration in flight mode 2 that enabled flaps and mixed in some throttle. I was using the fight mode switch for changing flight modes so when I flipped to stabile mode it mixed throttle in.    

I did a reset of the model and started over and all was well. This didn't happen with the APM, it happened with a NAZA, but the same scenario could happen..

Thanks Richard, I did use a new model setup. I have a Spektrum 8x, I did check to see if there were any mix's when I first set it up. I will double check. The helpless feeling, I also am not sure how this one came down, as you can see in the video it flipped and slowed its fall to the tree...

Sorry to hear this Tony,

Can you supply your .log file of the flight.

Thanks, Leonard

Thanks for looking at this Leonard.  There are 14 log files with the same time-stamp, this is the biggest one, do you want them all?




Not sure thats the right tlog as nothing happens.

My ‘headline’ flyaway was just in auto. It was behaving in all other modes, Loiter, RTL etc, and on previous slower missions. It was like it got an adrenalin buzz from flying fast and then didn’t want to turn the motors down. I vaguely remember I may have tweaked the ‘Throttle rate P’ up before that flight but not much.


Previously, while doing the PID tuning I had set a value on CH6 slider (cant remember what it was) but while adjusting it the copter just started climbing. It wasn’t until I got the throttle at the bottom that it chopped the motors. Whatever I was adjusting turned the throttle into an on-off switch. Fortunately I managed to drop the slider and recover.


The issue of covering up the pressure sensor from turbulence, I suspect would only cause height inaccuracies. I would be suppressed if it was responsible for these runaways.



Yep, this looks like it is the one.

Ok, I have had a look at this and I can see what has happened, with the help of Randy.

So what was happening was you were switching into return to launch every time you dropped your throttle because your throttle failsafe value is too high. So you were switching into RTL over and over again.

So every time you dropped your throttle you went into RTL, and your copter tried to climb 10m (know problem that is fixed now).

New wiki page for 2.9:


The one thing that does look wrong with your sensors is that your Baro seems to be jumping all over the place! You may not have covered your baro properly.


I will make sure 2.9 is loaded.  As to an explanation to the switching.. I thought I lost control, so nervous switching took place. I had only two modes (Stabilize and Alt-Hold) and I couldn't get one of them to respond.  As my throttle stick was at zero (closest to me) wondering why it was going up...So now some of it is becoming clear. The APM board is on the top exposed to the elements, so maybe I need the new plastic cover.

I'll check in when I have the new parts.

Thank you again.


The problem is that you were dropping your throttle to zero and going into FailSafe ie RTL. This is because you have your FailSafe Throttle set too high. This is why you couldn't get Stabilize and Alt-Hold to respond.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service