I am having trouble running MAVProxy in my computer (Windows 7) to connect to my quadrotor. I have downloaded both MAVProxy and mavlink-1.0.9 and not changed anything in them.

 

The PATH in Environment Variables has been updated to be:

C:\Python27\;C:\Python27\Scripts\;C:\Users\...\Downloads\Mav

 

A command prompt has been opened, cd to directory where mavproxy.py is at, then I try to run the module by typing:

python mavproxy.py --master=COM5

 

I get the following error:

Traceback (most recent call last):
File "mavproxy.py", line 20, in <module>
from MAVProxy.modules.lib import textconsole
ImportError: No module named MAVProxy.modules.lib

 

I have tried troubleshooting the problem a lot of different ways by modifying the folder names, relocating the folder names, etc. Any help is appreciated!

Views: 2922

Replies are closed for this discussion.

Replies to This Discussion

Hi,

I got that error too and fixed it by uncommenting in mavproxy.py:

# allow running without installing
sys.path.append(os.path.join(os.path.dirname(os.path.realpath(__file__)), '..'))

I also checked out mavlink to the same parent dir as MAVProxy and did (Linux) inside the MAVProxy dir:

dongfang@dongfang-ThinkPad-T60:~/workspace/MAVProxy$ ln -s ../mavlink/pymavlink
dongfang@dongfang-ThinkPad-T60:~/workspace/MAVProxy$ ln -s ../mavlink/message_definitions

This makes links to necessary stuff in mavlink. You can also just copy it if your OS does not support links well.

Regards

Soren

Great thanks!  I have sorted out the file folder directory problems, and un-commenting that line of code does help. Thanks again

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service