Hi All,

I'm currently running MP 1.2.7 and Arducopter 3.0.1 and when I move the Yaw and Pitch sticks nothing is sent to the motors. Throttle and Rudder seem to work and as I change the them the motors respond, but if I change the Yaw or Pitch no change in the motors occurs. I have erased the EEPROM, reset to factory, reloaded firmware, calibrated radio from the CLI and Mission Planner. When I go the Raw Data view and look at the radio, I see the values for channel 1 and 2 change, but on the output nothing changes.

I'm sort of at a loss as to what's changed. Everything was working fine, then it all just stopped.

Please help



Views: 271

Reply to This

Replies to This Discussion

Try moving your radio connections around and see if the problem is with the APM or receiver.

I don't think it's the receiver as I'm am seeing the values change in the Mission Planner. One thing I can't remember how it originally worked, was if I go into the Radio Calibration, the little lines which appear on the bars are always in the middle and I need to move the radio to the ranges to set the settings. After I save it, when I disconnect the APM and reconnect and go back, none of the settings are remembered and I need to go in again and calibrate. It's as if the settings are never saved in memory on the APM. I've also tried calibrating the radio on CLI and the same thing happens.

I've read somewhere about doing an erase and a reset but I did both of these things and nothing changes..



Lets say your Elevator (Pitch) is CH1 on your receiver. Connect the servo lead from CH1 to the Throttle channel on the APM and see if you can get the throttle to move in the configuration screen.

I switched the aileron and throttle on the receiver and throttle was now controlled by the aileron on the remote so it seems signals are coming in correctly, but the APM is not registering aileron or elevator. When I go the Raw Sensor window and show Radio, Radio In is registering movements on the remote control. But Server/Motor out doesn't change when move the Aileron/Rudder. If I move the Throttle or Rudder, i see the 4 motor outputs work correctly. 

I tried an earlier version of Arducopter but that didn't change anything. Not sure what could be causing this, it doesn't seem to make sense.

Is there any logging to see what is happening realtime?



Do you have another APM you can test with? See if your APM output is messed up?

Thanks so much for you help. I ended up doing an erase and reset. Then I went to a previous version, then I upgraded back to 3 and went through all the calibrations and it seems to be working fine. I haven't flown it yet, was looking at raw output and things seem to be working correctly. Will try and fly again today. I'm not sure what caused it, maybe some PID tuning that I've been doing, I can't be sure.



Reply to Discussion


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service