I finally got all my motors wired up and loaded the APM with the hexa firmware. I set up everything as I had done before. I plugged in the battery, armed the motors and was prepping for the maiden flight, this is where the issue begins.

I slowly raised throttle only to have 4 motors spinning. At 25% throttle motor 4 kicked in (but noticeably slower than the others) and then at 50% throttle motor 1 started up. I rebooted the APM and same thing happened. I may try to reload and do the initial setup again tomorrow. I also need to verify wiring (although I checked about 4 times) because the motors don't seem to do,the expected given my stick input.

Anyone else have this issue?

Views: 1370

Reply to This

Replies to This Discussion

Have you run ESC calibration? Take a look at this: http://code.google.com/p/arducopter/wiki/AC2_ESC

I did run the initial calibration and I thought they all worked fine...obviously they don't. I'm going to start from scratch tomorrow and reload the firmware and go through all the steps. I'm hoping that solves it.

Just wanted to make sure this was an isolated thing, and if it isn't, figure out the solution. Thanks for the quick reply.

You may need to do the manual calibration of your ESCs. Also, just double check the wiring... I have sworn I had everything connected properly only to find a problem.

Ya. I've done that way too many times. I'll check that first then start over. I'll give the manual calibration a try also.

Well I hope you get it figured out... sometimes walking away and coming back helps in and of itself.  Good luck!

Thanks. I'll post back once I have a solution just for reference.

If they all are calibrated properly (you can check by attaching ESC wires to the receiver throttle channel and check that the throttle range is the same for all of them) the other possibility is that your copter is not level - or it thinks so. Does it show horizon as level in Mission Planner? Try recalibrating autolevel and try again.

And btw the ESC calibration never worked for me on hexa, only 4 motors spun up. So maybe you missed two of them this way.

I reloaded my firmware and calibrated the ESCs and that has solved one problem. Turn out my ESCs are not plugged in correctly so I need to go rewire them.

I also seem to have a more serious problem...my copter doesn't have enough power/lift to achieve lift at a reasonable throttle level (70%). Is this normal? I would have expected it to lift off with much less. I am spinning 10x4.7 props on 1100kv motors. The hexa weighs in at 1.9kg.

I am looking at getting much lower kv motors and going to 12" props. Would that help?

Any help/insight would be appreciated.

It sounds like you should be able to get lift at 70% throttle. If it is possible hold the hexa and see if you are getting any lift at all. Maybe your props are backwards, or your motors are still connected incorrectly.

The motors are connected correctly. I am going to rewire an the test again. My suspicion is that I'm not generating enough thrust to lift te heavy frame up. What is a typical hexa weight?

My flyduspider is 1.5kg with battery, 1.7kg with gopro, and still lifts up at ~60% throttle. Ideally it should lift with 50%. There is no answer to how heavy it should be, I had larger motors in there that added +300g themselves, but there is usually a typical weight for a particular frame.

However at 1.9kg it shoul lift just fine with 10" props. Is your battery hot? Are you using 3S battery with that motors?

Yes, I am using a 3S battery and it isn't getting hot.

Assuming the motors aren't cutting it, I am using eCalc to find the best motor for my copter and I've narrowed it down to the following:

Turnigy 2217 20turn 860kv 22A Outrunner

Turnigy D2836/11 750KV Brushless Outrunner Motor

NTM Prop Drive Series 35-36A 910Kv / 350W

The NTM is not preferred because of the price and the 6 new ESCs I'd have to get. With those I'm not getting a flight time of more than 6 minutes.

What are you getting for flight times with your copter? Also, what battery are you using? Could you post specs so I can compare?


Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service