Hi,

I've been trying to set up antenna tracking using Micro Maestro (http://www.pololu.com/catalog/product/1350)

but so far wasnt able to make servos move.

I followed these instructions: http://code.google.com/p/happykillmore-gcs/wiki/Tracking

I can control servos 0 and 1 through Pololu software.

 

Also tried with ssc03a driver using both pololu and mini ssc 2 protocols but no success there as well.

As soon as i move a slider to turn servo, red light (serial error) comes on. 

Connected usb-to-serial out on pc directly to rs232 input on this board using only 2 pins (serial in and ground.) Powered through bec i had laying around.

 

Anyone got experience troubleshooting this?

Thanks

Views: 1686

Reply to This

Replies to This Discussion

What version of the GCS are you using? You'll need to select the Maestro driver option as I've no no luck getting a Maestro servo to move with MiniSSC or the old Pololu protocols.

I got 1.3.29 lite and was using Maestro output mode

Sorry, after further looking, it says it supports Pololu and MiniSSC II. In my experience, MiniSSC II has been the "default" protocol. When you look in device manager, do you see one or two COM ports that get added? I've seen the Command port and the TTL port.

 

The other thing is I assume you're powering the board since you've got it moving in the Pololu software.

Still not sure I've identified the right device.

 

Maestro Protocol (Pololu) -  Download the Maestro Software http://www.pololu.com/docs/0J40/3.a

  1. Launch the Maestro Control Center with your Pololu board connected (and the GCS turned off)
  2. Serial settings tab, select USD Dual Port and press Apply Settings. 
  3. Make note of the device number (12 by default), this will be used on the calibration window of the GCS.
  4. Channel Settings tab you may want to change the min value to 0 and the max value to 3000 for channels 0 and 1. They can be limited using the calibration window in the GCS but failing to set these values in the Maestro Control Center will physically disallow the servos to move outside of the 1000-2000 range in the GCS.
  5. Channel Settings tab set speed to 1000 and acceleration to 255 for channels 0 and 1.
  6. Apply Settings
  7. Launch GCS and select Maestro Protocol, Select Command Port (not TTL in device manager), Baud rate can be set to anything (will auto detect baud rate).

I use USB Dual Port mode, and see 2 ports, COM8 & 9. 8 was TTL, so I was using port 9

Perhaps i made first post a bit confusing.

I got 2 separate boards that i can not get tracking working with:

1 - Micro Maestro http://www.pololu.com/catalog/product/1350

Supports Maestro mode in HK GCS

It is set according to same instructions you posted above

I'm pretty sure i'm hooking this one up right since i can move servos from Pololu provided software.

This one runs data though usb cable, and +5v power for servos from separate source (bec in my case).

2 - SSC03A http://www.pololu.com/catalog/product/207

Supports Pololu mode and MiniSSC II in HK GCS (selected by jumper)

Not so sure about this one, since i cant find a simple test program.

It is connected through regular serial cable to my serial port using usb-to-serial cable.

Power for servos also comes from BEC.

I believe there is some power separation on the Pololu boards. +5V on the servos alone may not be enough.

Did you have chance to make Micro Maestro running? I got today Micro Maestro, followed the instructions, but still not able to drive the servo on HK GCS. On Polulu Maestro Control Center I can move the server OK. But in HK GCS v.1.3.32, not moving (frozen) when try to calibrate. I did try Maestro, MiniSSC and Polulu drivers, but no success. My servo is powered from the PCB pin +5 and works fine when driven from Polulu software. Should I use an external power? Why works in Polulu s/w and not in HK GCS. Any clue? I use USB dual port as in instructions. Both applications are open (first Polulu, then HK GCS), works in Polulu but not in HK GCS. Thanks. Chris

I have the same problem with the 6 servo, works fine with the 24 servo.

 

I did try it on another PC (XP) and HK GCS and Maestro 6 channels it is working fine. The initial PC (W7) where I did try first time, still not working...

Hi TSnoke,

Explain to me please how do you assign the comm ports on HK GCS. Do you need to share ports?

I did try next scenario: I did shared 2 ports COM7<-COM8 and COM7->COM8. Then I did start GPS emulator on COM7 and connect HK GCS to COM8 and I can see Serial data. Then I disconnect COM8 for Serial and connect Tracking to COM8. I would expect to see servos moving, is that correct? Do I need to keep Maestro Control Center connected? I believe this is just for calibration purpose. I am little bit confused. So I see data coming from GPS(real/emulator) on COM Port tab/Serial Data. But I don't know which COM port to use for tracking. As I said, tracking calibration is OK (servos are moving), but I can not make servos moving when I follow the GPS position.

Thanks, Chris

Sorry guys, I'm a bit swamped right now.

 

If you want to use the emulator, you should make sure in com0com that you select "Enable buffer overrun" on both sides of the connection (COM7 and COM8 in your case criro). If you don't select that option, then you have to hit "connect" in a certain order (I think it's emaultor first and then GCS).

 

So then on the Emulator, click the Protocol tab and select something. I usually use the 3 checkboxes under "ArduPilot" because this has one of the most complete sets of data. Click Exit on the Protocol window and select COM7 and any baud rate (115200 for example), then click Connect and Start. The next time you launch the Emulator, all that will already be set and it will start sending data immediately.

 

Next in the GCS, select the COM Port tab and choose COM8 and any baud rate (115200 for example) and click Connect. At this point, everything should start moving. Your Google Earth, your instruments. You should be able to see the data is now flowing from the Emulator to the GCS. If this isn't working, stop here. This has to be working to move forward.

 

Next, click the Tracking tab and select the COM port for your physical USB to serial cable connected to your Pololu. You want the "command port" not "TTL". You can find this in the device manager (Emulator, Computer looking button to the right of connect, then Ports, COM & LPT). You need to make sure you have configured your Pololu accrding to the directions here: http://code.google.com/p/happykillmore-gcs/wiki/Tracking under Maestro Protocol (Pololu). Once configured, in the GCS, select Maestro Protocol, Baud rate can be set to anything (will auto detect baud rate). Then click connect. At this point, your servos should start moving. I believe you need to apply external power to the Pololu board to get the servos to work as they are not powered by the USB.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service