• Hi there! :-)

    Sorry for opening again the old one, but I couldn't find anything else regarding my issue..

    I just came across a similar problem. My horizon is drifting slightly. While arming, I have a yellow flashing led (pre-arm error). I opened MP, and counted out every element, which is listed on prearm list. It turned out, that it has no gps lock (doing it indoors - normal), and INS are not calibrated (however this wasn't flashed on the HUD, and I have calibrated accel many times). I am not using any external compass (plane), Tried to calibrate inner compass (PX4), and it threw out compass 1 error: 99 (same for compass 2, and 3), but it started to collect samples, and in the end I got information, that calibration ended with success.
    Trying to arm the plane - everything goes round again - it doesn't want to arm, yellow led, etc..

    If I deselect GPS lock, and INS - it works. The led blinks blue (no gps lock), and PX arms, but what is wrong with the INS?

    Did anyone have to deal with that kind of problem?

    Best regards,

  • Ah....
    that explains why my gimbal keeps jittering and moving while disarmed and sitting on a flat surface...

    APM 2.5 with 2.9.1 and a uBlox on a tricopter

    cheers Christoph

  • Developer

    I am having a similar issue when I attach the Air speed sensor on arduplane 2.7.  not sure why airspeed affects the AH, so at the moment I fly without the airspeed sensor.

  • its known issue

    set advanced parametr ahrs_gps_gain =0

    for disable horison moving while GPS drift

    its parameter must correct horison on airplane in spin and cant be used on arducopter

  • I recently brought up a PX4 (with Ublox GPS) and noticed my horizon moving around while board was sitting still on table.

    The UBlox GPS does much better and faster fix than the Mediatek in my APM, but on my APM the horizon doesnt move while it is sitting still.

    Seems to me that the GPS should never affect the horizon in any case, it simply reports position and altitude.

    The Accelerometers and Gyros determine horizon attitude, not the GPS.

    So, if it is the GPS causing it, it is because something is wrong with the software.

    And, even if it isn't, it still seems like it's got to be something wrong with the software.

  • This is normal and a funny little quirk of the current code. If you arm you should see the horizon settle. THere are moves to correct this due to the confusion it's causing, but for now just arm it and see.

  • I had the same issue with ArduPlane 2.7 on 2 different APM 2.5's.  Are you by chance using the uBlox GPS?  I was getting the artificial horizon start to jump around with the uBlox attached.  I swapped the uBlox out for a MediaTek and the issue went away.  For me the issue is reproducible.  I have tried 2 different uBlox GPS on 2 different APM 2.5 and get the same result.  I put the MediaTek GPS on both APM's and the instability issue goes away.  I suspect its a software issue with the uBlox hardware drivers, but that is just speculation.

  • what means "horizom moving"? 2.8.1. or 2.9.1?

    up and down? or tilting left or right?

    i believe this is not related to GPS but to gyros.

    try to redo the calibration in CLI. I did have similar issue in 2.9.1, not in 2.8.1.

  • I m also having the same problem !

    I think there is some problem with Barometer readings.

    i have tested barometer separately using Arduino IDE example code (comes in the package ArduCopter 2.7.3 ) and found that altitude reading is fluctuating too much within 2 meter range.

    guys plz check out and let me know if u guys also getting same results.

    and plz help me with this problem if anyone can...

  • I have the same problem

    I really don't know what is going on

    same story here ...APM2.5, gps lock, tuned magneto, everything ok.   hexacopter on the table, but horizon moving like 

    in a storm.


This reply was deleted.


Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24