As the title says, I couldn't find a way to report a bug on the latest Mission Planner to the devs. Does anyone know the proper channel to do that?

After upgrading to the latest MP (1.3.19), the MP doesn't open anymore and it crashes on the splash screen. Even uninstalling and reinstalling a couple of times didn't fix it.


Cheers,

Hugo.

Views: 1287

Reply to This

Replies to This Discussion

https://github.com/diydrones/MissionPlanner
In the mean time, try APM Planner 2

please post your config.xml file inside the mp directory.

and then delete it

Huge thanks, Michael. Crazy you found the time to reply here. That worked great, I should have thought of deleting the whole folder after uninstalling.

Here's the config file attached.


Attachments:

hi mission planner is not opening y?? and what is the difference between apm planner and mission planner? thx u . and what is the config.xml  i didnt find it in the directory

i have the same problem did u fix it and how ?? and im not finding the config.xml file in the directory

hi i have the same problem. it is not responding on the start screen. and im not finding the config file. what should i do ?

please provide missionplanner.log, as I have nothing to go on.

I'm having the same issue. The start screen locks and the command prompt asks me to hit any key to exit. 

Here's a screen shot:

http://i179.photobucket.com/albums/w320/gravityisnotmyfriend/Aerial...

And here's the log:

2015-02-26 18:44:31,685 INFO Program - ******************* Logging Configured ******************* (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Program.cs:47) [1]
2015-02-26 18:44:34,899 INFO MissionPlanner.MainV2 - Mainv2 ctor (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\MainV2.cs:288) [Base Thread]
2015-02-26 18:44:36,071 FATAL Program - Fatal app exception (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Program.cs:217) [Base Thread]
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: Font 'Arial' does not support style 'Regular'.
at System.Drawing.Font.CreateNativeFont()
at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
at System.Drawing.Font.Initialize(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
at System.Drawing.Font..ctor(SerializationInfo info, StreamingContext context)
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle._SerializationInvoke(IRuntimeMethodInfo method, Object target, SignatureStruct& declaringTypeSig, SerializationInfo info, StreamingContext context)
at System.Runtime.Serialization.ObjectManager.CompleteISerializableObject(Object obj, SerializationInfo info, StreamingContext context)
at System.Runtime.Serialization.ObjectManager.FixupSpecialObject(ObjectHolder holder)
at System.Runtime.Serialization.ObjectManager.DoFixups()
at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Resources.ResourceReader.DeserializeObject(Int32 typeIndex)
at System.Resources.ResourceReader._LoadObjectV2(Int32 pos, ResourceTypeCode& typeCode)
at System.Resources.ResourceReader.LoadObjectV2(Int32 pos, ResourceTypeCode& typeCode)
at System.Resources.ResourceReader.LoadObject(Int32 pos)
at System.Resources.ResourceReader.ResourceEnumerator.get_Entry()
at System.Resources.ResourceReader.ResourceEnumerator.get_Current()
at System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)
at System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)
at System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)
at System.ComponentModel.ComponentResourceManager.ApplyResources(Object value, String objectName, CultureInfo culture)
at System.ComponentModel.ComponentResourceManager.ApplyResources(Object value, String objectName)
at MissionPlanner.MainV2.InitializeComponent() in c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\MainV2.Designer.cs:line 76
at MissionPlanner.MainV2..ctor() in c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\MainV2.cs:line 303
at MissionPlanner.Program.Main(String[] args) in c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Program.cs:line 213

I'd really appreciate any help getting the program to load. 

FWIW, I'm running XP with Net Framework 4.0, DirectX 8.0 and the latest video driver. 

Hi Hugo,

There has been a recent update to NET Framework 4.5. Have you updated?

I just updated to MP 1.3.19 manually and it started without the issue you are seeing. I am running Windows 8.1 on an HP laptop.

Regards,

TCIII AVD

AC 3.2 is not available in the previous versions drop-down list

Won’t update to latest version?

I am using 1.3.17 and it never tells me that a new version is available. How do I turn that feature back on?

.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service