I'm currently connecting my APM2.5 to my pc using a usb. When i connect it to the pc using the mission planner the Roll Pitch and Yaw are always waay off from the actual orientation of the board.

I have discovered the values for roll pitch and yaw seem to tend towards the values 90, 45 and 120 respectively. When i turn the board i see changes in these values however it always goes back.

I have made no changes to the code whatsoever, I've even reuploaded the firmware using the mission planner but i still get this. Has anyone encountered this before or have an idea what might be causing it? And if so, how may I rectify it?

Views: 534

Reply to This

Replies to This Discussion

Have you gone through the configuration process, including the level command? 

Yes, I did that a few times now but it did not fix it

Actually scratch that. I attempted re configuring it again and it seems to be back to normal :-). However, its not arming anymore even though i'm holding yaw to the far right. :/

You may have the throttle or yaw channel reversed. Check those.

you were right, however, apparently, the case wasn't that my yaw was in reverse but that it wasn't in reverse. I put it in reverse and that seemed to fix it. :-)

Correct me if I'm wrong but,if putting it in reverse fixed it would this indicate that my transmitter is configured incorrectly? (or something along those lines)

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service