I can't get my SkyWalker to Fly with APM 1 and Arduplane 2.28 !

I'm a novice with APM and have great difficulty doing what seems to be a walk in the park for most others. I can't get my Skywalker to Fly ! 

I have spent several days over the last three weeks trying to fly and several nights trying to figure out why it didn't,  tweaking and carrying out repairs - thankfully the Skywalker is a tough plane. To explain my problem I will outline the spec, describe what is happening and what I have tried so far.

The Specifaction -

Skywalker 1.68m wingspan.


BEVRC 2814  kv980 motor

APC 9x6 prop

APM with Arduplane 2.28 installed

Main Battery 4S 5000mAH

Second battery for servo and also FPV - 2S - 2.2Ah

The overall weight including the FPV gear is a little above 2Kg (i.e. 2080g). I know this is on the heavy side but I've seen several people flying at about this weight.

What it's doing ......

I have been trying to launch it in stabilize mode and I am launching from hand. I feel I have to give it full throttle or close to full so that it will build up airspeed - if I use less throttle it touches down before building enough speed to fly . The problem is that within about 100m of launch (within a few seconds of launch) the aircraft tends to bank either left or right and rather than correct with the stabalise function it continues to climb a bit but rolls and heads for terra firma. The severity of the decent depends on altitude achieved and if I cut power before it comes down.   Although I can see the aerilons trying to bring it back it seems to have no impact on the way the plane flies.  Unfortunately the behaviour varies a little so I can't pin point what is happening - e.g. it sometimes banks left and sometimes right.  I have tried more than 20 launches while changing many little things and I still seem to get the same..... I'm now pulling my hair out and feeling particularily stupid as I guess it's something obvious.

What I have tried.

In all the pre-flight checks everything seems fine - the aerilons etc respond as they should when still on the ground.

I have adjusted the PID and specifically increased P on the roll so that it might correct more seriously before the plane rolls too far for recovery - no change.  I was already using the Skywalker config off the DIY drones site and the P roll is already set to 3 which I think is already very high. I haven't changed anything else on the PIDs from the Skywalker template on DIYDrones.  

The trim on the plane is fairly good - I have moved things around a little to make it slightly nose heavy for some attempts and then fairly balanced for others - no noticeable impact. My aerilons, and rudder are trimmed Ok also and generally I have the elevator trimmed slightly up to help with the launch.  

On one occasion I did get it up high enough to change to Auto but on that occasion it simply flipped up side down and continued to fly upside down but didn't climb to the assigned waypoint. Because it didn't climb it clipped a tall hedge in the next field and came down.  I discovered I had dip switches wrong which had an impact in Auto (i.e. made it fly upside down) - I corrected this but no improvement on the launches  haven't managed to get high enough to get into auto again since.

I have always had a well charged main battery and it seems plenty of power. One observation is that the motor seems a little stiff to turn by hand and not sure if it might have taken a knock on a rough landing but seems to run fine when powered up.

I have adjusted the horns on the servos to get more movement on the surfaces but no difference.

As you might imagine my Skywalker is now a little battered but apart from a bit of tape all repairs have been fairly clean and it has kept it's shape.  I have a new replacement Slywalker body but don't want to start using it until I figure out what's going on.


I also wondered if I had a problem with the APM (e.g. a faulty sensor) but can't see what and as I said it works Ok in pre flight.



I guess that because of my inexperience I am doing something very silly and basic but for the life of me I can't think what it is - any help / suggestions would be greatly appreciated.


 Many thanks



Views: 484

Reply to This

Replies to This Discussion

First, don't launch in stabilize mode. Launch in manual and only switch to stabilize once you're at a safe height, to tune it. Second, if it's flipping upside down, you almost certainly have your aileron direction reversed. Click the reverse checkbox in the MP RC setup. 

Thanks Chris for the fast reply again.


For the flipping upside down the aerlon direction was reversed and I have fixed that one.  I think that my problem was with the dip switches on the board.

In relation to launching in stabilize mode I thought that this would be better than just manual in that it wouldn't stop me using the controls but would help level it as soon as I let the sticks go. I understood that if I use the sticks in stabilize mode then it's more or less the same as manual.

I will try as you suggest.


Thanks again




It's best to do the reversing in software via the MP. That disables the DIP switches, so there is no chance they'll get accidentally moved at the field. 

Stabilize does let you fly manually, but you shouldn't use it until your aircraft is tuned and tested from a safe altitude. It's certainly not the way to take off the first time!

Thanks Chris


I'll try manual mode launch tomorrow.






I am going through much the same pain in the maiden of my Skywalker.. Many crashes, lots of gorilla glue, it looks a little beat up, but still looks air worthy.. yet I still cannot get it launched...

I am now thinking I am going with way too much throttle on launch, I am using a 9X6 prop with 1400 motor 3s bat.

Did you get it all sorted out?

Hi Mack

After many unplanned crashes back to terra firma I have started to make good progress but haven't got everything solved yet. At this stage I am launching ok and the Skywalker flies very nicely (smooth and level) but now my problem is that it doesn't seem to go where I want it to go in Auto. 

In terms of power I have a 4S and also a 9x6 prop but a slightly slower motor (925KV) and while this combination is alot of power and makes things happen fairly fast I'm happy that too much power wasn't my problem. The biggest problem was mostly my inexperience and that I had my aerilons reversed in auto and took a while to realise this and also had issues because I hadn't a compass installed to it couldn't steer properly in auto (steering on GPS without the compass does not work very well especially if you have lots of power). With a powerful plane andflying auto without a compass means that the plane can go a little nuts when trying to find its way. Also I did some silly things like forgetting to reset my launch altitude on one flight meant that my plane headed to WP1 when I turned on Auto but unfortunately because I didn;'t reset my launch altitude the plane determined that the WP was about 70m underground - as you might imagine it was like a kamakassi scene from Pearl harbour and this crash meant I decided it was beyond patchwork and I had to build another airframe.

My current problem is that on my last flight it launched very well and when I switched to auto it seemed to be heading to WP1 with correct altitude but then it flew through WP1 and didn't steer to WP2. When I checked the data, I found that it had logged position when in manual and stabalise mode on takeoff and just before it landed but during auto mode it recorded nothing - I have been investigating  and not sure yet whats happening but will try again tomorrow.  Some things that I have found is that interference from a mobile phone can cause the plane to switch modes, I have found that a solid blue light on the mediatek GPS does not mean you have a position fix but just that it has found some sort of satellite and fixing a position can take some time.

I'm also not sure whether I am seeing interference between the ESC and APM and GPS but have to do more testing on this. My ESC is probably too close to my APM.

Also one thing that i thought might be happening on my launch is what some forums have referred to as torgue roll where full power on the single engine plane tends to cause the plane to roll on launch - I have tried to trim slightly to compensate for this but I'm not sure if this was a real problem or just my imagination and novice flying skills.

Also my main outstanding issue is that I have no data telemetry as I couldn't get the xbees to work on 868 Mhz. I am currently trying to solve this and making progress. I believe that this is important before launch to check that everything is working and you have a GPS fix and also important when you are airborne to be sure of your mode is as you expect. At some stage I will try to implement audio for confirming status of GPS fix.

I feel that I am fairly close to having everything working well and I'm putting my early problems down to inexperience and a little too much haste because of my enthusiasm.






Thanks Jon for the detailed update.

I am fairly inexperienced as well, and just trying to launch the SW is giving me fits.. now I am just waiting on a day without 15 mph gusts to try it again.

thanks again.

My beaten up SW...

Hmm, it sounds like we're all having some trouble with our planes not believing in those waypoints. When my team runs hardware-in-the-loop simulations our plane flies fine, so we believe our PIDs are perfect. However, we're having the same issue with physical Auto flight not wanting to go to the waypoints. The difference is that our plane doesn't just go through the waypoints at all. Instead, it decides to fly around in circles for a bit, and progressively decline until we switch to Manual and right the plane (sometimes the throttle cuts out so we end up having an emergency landing).

Our HK Bixler is definitely more beat-up than that. I'm surprised it can fly at all.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service