I think thats it for me with ArduCopter and APM 

after all day of testing and adjusting things like PID's etc and all day failing
(5 serious crashes) 

i think its time to hang up the boots, 

my copter flew brilliantly in manual mode but as soon as i tried to use anything autonomously it would just act up and fly around like it had no idea what level is.

attached is the last and final crash, which literally obliterated my copter and i have nothing left except a motor id say.

Views: 972


Reply to This

Replies to This Discussion

is there any way possible i can go back to the 2.9.1 firmware? 
3.0.1 has ruined me.

Yes - there's an option in MP to download previous versions.

I feel your pain - my problems were due to compassmot. I bit the bullet, stopped flying, and got the external compass before it killed my quad. My quad was on the bench for 2 frustrating weeks, but I do at least still have it today.

Yeah the most frustrating thing about today was i have quite an expensive quad racking in at $1100 without the rc controller, 

it has the Ardupilot APM with Upgraded 3DR uBlox LEA-6 GPS external compass, 

i dont know what it was it just would not work autonomously today


attached is a video of what the copter was doing during auto using waypoints :(

Have you tried to plan a mission with just 2 waypoints. Only out and back without lotier_tunrs aso. (coz there is some issues with 3.01) In just 6 m height.
Not a long mission, just 20 mtr away, and back with RTL. (maybe your esc or motor gets hot)

I always start with 30sec on the ground, then arm wait 5 sec. and then start the motors i 1 m height. then alt_hold and then increce to 2m and do lotier.  If this work i'll try RTL from 5 meters away. My RTL i "raise to 6 m and then decent" . If all this works i'll go further with the programmed mission.

The 'cautions' with the 3.0 release said:

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode. You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).


Warning #4: loiter turns does not maintain altitude. This bug will be fixed in AC-3.0.2.

I noticed that you're loiter P was still 1.0. Where you in loiter during any problems?


It also looks like you have not done the compassmot since you upgraded. The compassmot params all say "0" in the logs. Reducing interference is extremely important with 3.0

Good luck-


the only trouble i ever got was when i was using the copter in auto mode, i never really tried it with loiter as i would manually make it loiter with my RC controller, 

i had not seen the compassmot info or anything before or after upgrading to 3.0 ill have to do some more research on it before i go back to 3.0 i think,

the only trouble i ever got was when i was using the copter in auto mode, i never really tried it with loiter as i would manually make it loiter with my RC controller, 

That may be why you have had trouble...

I followed advice on on the V3 blog post: First flight in STABILIZE, then try ALT-HOLD, LOITER, RTL and only then AUTO.

Took me a while with compassmot, some power distribution mods, then eventually an external compass to get LOITER sorted (and now it really is totally solid). RTL then worked great first time. Had two very successful AUTO flights since.

No probs i did acctually try loiter and alt hold when doing it before auto but i never did Compassmot which ill do soon, 

also does anyone know which way this external compass/gps is supposed to be pointing? (see photos)
also i dont think its a external compass as well, i think it is only a gps, so does this mean i can only use my apm 2.5 for a compass? thanks in advance!

That's just the GPS only, so it doesn't matter. The GPS/Compass has an arrow on it...

You can get the magnetometer on it's own, to save you having to buy another GPS. 

This is the same device as the one that's out of stock on the 3dr store:


awesome thank you, i think ill just grab a compass/gps soon as one and mount it on something high so i dont have any interference, 

Hi, some questions.

is downgrading to firmware 2.9.1 possible whitout any restriction possible?

what should be the better things of firmware 3?

when is the update of firmware 3 to expect.

kindly regards from

Dick Gerritsen

the Netherlands

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service