I had a crash today where my 3D6 RTF Y6 seemed to be a glide slope type landing with no control from my end

Today I was doing a manual flight using my DX8 radio for the 3DR Y6. I was trying to get some video while flying a remote area over a near by river. At about 6 1/2 minutes into the flight and with a reported 50% remaining in my readymaderc 8000mah battery. The Y6 seemed to switch into a fail safe or unknown mode where it wanted to land while in motion and would not take commands from the remote. When this occurred, I was flying in loiter mode at 15mph with a 1.2ghz video transmitter and I witnessed the whole event live. I tried to override the thrust by going to stability mode and it still would not increase thrust or follow the movement commands I was giving it. I was very lucky today because the Y6 missed the water completely and didn't even break a blade. Here is a link to the video of the whole flight. https://vimeo.com/84828838 At about 6:33 "end of video" you will notice the copter starts the oscillate more than the camera gimbal and take out and the motors sound erratic. Now I still have to adjust the PID's which I'm in the process of doing. Here is what is strange is this doesn't seem to occur when on a autopiloted mission or when in stability mode. I've flown it in stability mode over 55mph ground speed. The only time I've seen it happen is at low attitude under 150ft and under or around 15mph. Is there some sort of adjustment or PID change I need to make to correct this issue? Am I just losing radio signal and the Y6 is doing some sort of auto land fail safe?

Additional information:

Radio DX8

APM 2.6

3DR telemetry with Mission Planner 1.2.92 ground station active during flight

1.2ghz video transmitter on for FPV viewing

Crashes have occurred from 281 to 558 yards away through forested areas while in moving loiter mode.

 This was going to be a great flight until the obvious happened. I'm just thankful it landed out of the water.

 

 

Drone Crash - barely missed the river from West Fork Armory on Vimeo.

Views: 2826

Reply to This

Replies to This Discussion

This doesn't look like the right log. As the landing site is different from the video. The log posted is visualized below. Pink is the Auto mission, following the white lines of the waypoints. The blue is loiter and the end of the mission.

The video looks like the copter switch to land mode, either due to a GPS glitch, or low battery. I'm not sure if you have FS_BATT enabled (the log posted doesn't) but you have the cut-off at 9.6 volts. Which is really low. The only real thing you can do at that voltage is LAND. 10.5 is a much better voltage to trigger a FS to RTL etc...

Yeah, your right. Different log. Also in both cases the copter went down with plenty of battery power left. I'm starting to lean towards that it was a loss of radio signal which caused the landings. What is weird is that it's set to climb to 200ft and RTL with a loss of radio signal. Any ideas of something that could be causing this issue?

Maybe a GPS glitch, as it will land in this case

see http://copter.ardupilot.com/wiki/battery-gps-and-gcs-failsafes/

Also, where you using a GCS, as the 915MHz/433Mhz radios have better range than the 2.4Ghz of the DX8. Trees also attenuate signals at 2.4Ghz very effectively. Water is so good at absorbing energy in the 2.4GHz range that it's the same frequency that microwave ovens use to transfer that energy to heat up your food.

PS: the Pixhawk/PX4 uses the GPS clock to set the filenames based on UTC for logs, so they are much easier to find.

You might be on to something. When running the 1.2 Ghz video downlink I've seen a "Bad GPS Health" warning come up, but it's usually only when the copter is first turned on, any only when the video transmitter is turn on before the GPS has time to initialize. I've tried separating the 1.2 transmitter away front he GPS as far as possible but it still seems to be the same issue. When the copter is in stability mode, the copter has never tried to auto land. I'm going to check out your recommendation and let you know how it works. Thanks you!

I missed that from your original post, and that is surely a problem. You need to look up Low Pass Filters for you 1.2Ghz TX see http://www.rcgroups.com/forums/showthread.php?t=1229589 as an example discussion.

That's a funky autolanding...why was there a glide slope? Shouldn't it have stabilized in one spot in GPS lock and then began a vertical descent?

That's what I was thinking too.

Not if you don't have valid GPS signal, and your copter is not trimmed level

see http://copter.ardupilot.com/wiki/land-mode/

If the vehicle does not have GPS lock the horizontal control will be as in stabilize mode so the pilot can control the roll and pitch lean angle of the copter.

Can you please post the log?

This happens allot to me as well, its the battery.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service