I've tried everything on here but it still wobbles and flips on takeoff.

Hi all,

So this is the first time I've sought help on here since I got my first APM (2.5 latest firmware).  I've managed to make it this far with all the good info here and in the wiki.  Here's my kit, followed by my problem.

Stock Gaui 330X-S

Spektrum 2.4Ghz Rx and DX6i Tx

So, I had the above taking off and hovering no problem with the stock ESC's (see here for make up of parts)

The ESC's that come with the quad are reputed as being of low quality so I decided to replace them with something a bit better to see if I could make it fly a bit smoother.  These replacement ESC's come widely recommended, so I got some.

Cut a long story short, I cut all the connectors off my old ESC's, soldered them all to the new ESC's and rebuilt my quad with the new ESC's.  Eventually figured out how to calibrate them (which I did manually) and I'm confident this has been done correctly (as I did it several times before locating the instructions and doing it properly).

My problem is, quad wobbles and flips immediately after leaving the ground.  I've ran through all the troubleshooting steps in the wiki numerous times yet I'm still experiencing the same problem.  The only thing I can't get working in the test is the motor CLI test:

Have you run the Motors command in the CLI Setup to ensure that all the motors are hooked up right, turning the right way and the pusher/puller props are on the right motors and oriented the right way?

The motor CLI test simply does not work for me, it just doesn't spin the motors as per instructions.  I have no idea why and I promise you I have quadruple checked that I have set everything up correctly.

  • All sensors tested and working
  • Radio Calibrated - all end points on 100%
  • Quad levelled
  • Props and motor in correct orientation, I can see which way they're going when they start/stop spinning from full speed
  • APM orientation fine (using 'x')

Here's the weirdest thing.  If I give the quad even just a little throttle then take my hands completely off the Tx, it'll sit there on the ground, all props spinning but they will very slowly speed up to the point where the quad will take off on it's own if I don't drop the throttle.

Another test I did was to hold the quad while giving it a little throttle.  It seems to work exactly how it should when I do this in that it will correctly compensate if I tilt it in a given direction.  If I only lightly held it, it tended to start wobbling.

I've tried everything that seems to be listed on the forums/wiki but am at a loss.  Could it be that I need to do some tuning of PID's before I can even get it to take off properly?  I didn't need to touch a

thing with the stock ESC's to get it hovering ok.

Please see my quick video of it increasing the throttle by itself and the flipping.

Flip Vid

Sorry about the "War and Peace" entry.  Any suggestions/questions are more than welcome.


Views: 7026

Reply to This

Replies to This Discussion

By the way; it may also because of im giving very low throttle at start. Later i managed to gain higher altitude 1 meter or so, and managed to switch auto-land and it landed even though high wobbling.

That looks promising. You can program them one at a time with the throttle stick, no problem. The factory settings are for auto timing, medium start. I believe it should be fast timing, fast start.


Thanks so much for your post here.  I was constantly wobbling on takeoff and crashing my new homebuilt quad and tried everything from firmware changes to CG changes to electrical.  I followed every single step in the troubleshooting page here: http://copter.ardupilot.com/wiki/troubleshooting-2/#ArduCopter_tilt... but none of them fixed the issue.  I thought I'd have to return my APM thinking it was defective.  But nothing worked until I tried tuning down my rate roll P.  This solved everything and now I'm a happy flyer.  So thank you!

I know this is a very old thread but I am having the very same problems as the gentleman who started this! Exactly! The throttle increasing on its own and the precise flipping. Mine is a larger and much more powerful quad, but same behaviors! I can't find if he resolved all of it! I'm desperate and almost ready to be done with it.

I have other Pixhawk powered multi rotors that are functional. Their own issues but nothing to this magnitude!


I also had similar issue and asked in above comments.

After calibrating ESC & Motors my problem was fixed mostly. Then I had to fine-tune PID gains.

good luck

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service