I've tried everything on here but it still wobbles and flips on takeoff.

Hi all,

So this is the first time I've sought help on here since I got my first APM (2.5 latest firmware).  I've managed to make it this far with all the good info here and in the wiki.  Here's my kit, followed by my problem.

Stock Gaui 330X-S

Spektrum 2.4Ghz Rx and DX6i Tx

So, I had the above taking off and hovering no problem with the stock ESC's (see here for make up of parts)

The ESC's that come with the quad are reputed as being of low quality so I decided to replace them with something a bit better to see if I could make it fly a bit smoother.  These replacement ESC's come widely recommended, so I got some.

Cut a long story short, I cut all the connectors off my old ESC's, soldered them all to the new ESC's and rebuilt my quad with the new ESC's.  Eventually figured out how to calibrate them (which I did manually) and I'm confident this has been done correctly (as I did it several times before locating the instructions and doing it properly).

My problem is, quad wobbles and flips immediately after leaving the ground.  I've ran through all the troubleshooting steps in the wiki numerous times yet I'm still experiencing the same problem.  The only thing I can't get working in the test is the motor CLI test:

Have you run the Motors command in the CLI Setup to ensure that all the motors are hooked up right, turning the right way and the pusher/puller props are on the right motors and oriented the right way?

The motor CLI test simply does not work for me, it just doesn't spin the motors as per instructions.  I have no idea why and I promise you I have quadruple checked that I have set everything up correctly.

  • All sensors tested and working
  • Radio Calibrated - all end points on 100%
  • Quad levelled
  • Props and motor in correct orientation, I can see which way they're going when they start/stop spinning from full speed
  • APM orientation fine (using 'x')

Here's the weirdest thing.  If I give the quad even just a little throttle then take my hands completely off the Tx, it'll sit there on the ground, all props spinning but they will very slowly speed up to the point where the quad will take off on it's own if I don't drop the throttle.

Another test I did was to hold the quad while giving it a little throttle.  It seems to work exactly how it should when I do this in that it will correctly compensate if I tilt it in a given direction.  If I only lightly held it, it tended to start wobbling.

I've tried everything that seems to be listed on the forums/wiki but am at a loss.  Could it be that I need to do some tuning of PID's before I can even get it to take off properly?  I didn't need to touch a

thing with the stock ESC's to get it hovering ok.

Please see my quick video of it increasing the throttle by itself and the flipping.

Flip Vid

Sorry about the "War and Peace" entry.  Any suggestions/questions are more than welcome.


Views: 7026

Reply to This

Replies to This Discussion

Wow. You've got a bucket of trouble, sorry to hear about it.

To be clear, this system was working - APM integrated into the Gaui and hovering - before you swapped ESCs?

To eliminate the 'throttle bump' issue try setting the throttle trim very negative (down). This is supposed to put the 'trip point' of the ESC above moving the throttle stick up. My DX6i is setup in ACRO mode.. DX6i pic I did it that way to eliminate the Ch5 movement with the throttle when set up as Heli. I didn't dig deeper to figure out if I could 'unslave' Ch5 in the radio.

Have you grabbed a log file from the APM immediately after one of these failed launches? It will show the throttle in/out values and could shed some light on the problem.


Yeah it's not great and I feel like chucking it all in but it's so rewarding when you fix something!

YES, the system was working fine before I swapped the ESC's.

I'll give that a try with the throttle.  I have my DX6i set up the same as yours but no trim yet.

Haven't grabbed the log file, I'm only new to this so I didn't think to look at that.  I will definitely figure out how to download it and post it up tomorrow.

Thanks for your help!

Hello, in my opinion everything is OK for the APM part and setup.

I can say that because the quad goes straight vertically. Stabilzation works perfectly

unless you wouldn't be able to start it on your really tiny room ...

Your ESCs look to have a "soft start". That explains the increase of throttle at start.

This function is used on traditional helis to takeoff smoothly and don't strip gears.

Next, i can see that you have also the break function activated.

When you put throttle at zero too "hardly", the ESCs stop directly the motor

and so the quad flips ...

Notice the perfect flip, a sign that the APM works perfectly and still managed some controls.

Reset your ESCs and make sure you don't have soft start enabled or break.

Good luck ;)

Hi there,

I've just tried to take off and the same thing is happening as expected.  I've attached three files from the last log that was on my flash card.  I've no idea what any of that information needs to if you're able shed any light o it I'd be grateful.

I'm going to go through and recalibrate my ESC's again to make sure I've got them set up as they should be.

Thanks again.



So I've recalibrated my ESC's (the manual way as it's the only way that seems to respond like the instructions suggest).  The limited instructions I'm using are here.

Before when I started my quad up I got three beeps, now I'm only getting one long one.  When calibrating the ESC's this time, I did each one twice.  Once for LiPo and then another for the brake.  I have no idea if the brake is on or off.

Either way, I'm getting the same results as before.  While it was on the ground I tested the radio inputs and each control (yaw, pitch, roll, throttle) is acting as it should when spinning up on the ground.  The only thing is when I yaw the quad tries to take of a little.

I've attached the logs again for this test as well.

Thanks again!


Hello, instructions are really simple ... Brake is enabled on first bips or seconds ?

To know if brake is activated, just try it on a single ESCs to see the difference and make sure there is no brake.

Nothing about "soft start" on instructions ?

If problem remains, just try with your previous ESCs to see if there is still the problem.

Maybe one ESC is faulty ...

I tried open your log file, and there is a lot of inputs.

Try to do a log containing only a takeoff sequence.


Thanks for your reply.

Everything I can find on these ESC's are linked to in above posts.  No mention of soft start anywhere.

I'll change back to my previous ESC's as a last resort, it'll be a pain to solder all my connectors back.  I will if I have to, I just want to ensure that I cover everything first.

All the ESC's program in the same way, spin up the motors simultaneously and as mentioned seem to react correctly when holding the quad in my hand and tilting with the motors going.  None of them give the impression that they're faulty.

I'll work out how to change the logging and get back to you.



I've had some progress.

As per this issue I was having the other day with my original ESC's where I had to power up the APM using USB before plugging in the main battery.  I could arm it but the motors wouldn't spin.  This resolved it for my original ESC's.

I didn't have this problem with these ESC's so I have never tried it until I thought of doing it just then.  I haven't completely resolved my issue but the quad is not flipping anymore.  I can actually get it into a rough hover.

So it's up and controls seem ok but it's wobbling like crazy and is difficult to control.  It's this something I can resolve by tuning PID's (another thing I have to learn)?  Or do I still need to look elsewhere?

Thanks heaps for your help as always.

Great. For the wobble try to lower P values on stabilization ...

I noticed that if i connect a red wire from my Rx to the inputs it will have the same issue as your ... motors won't initialize and don't spin.


Here is my APM connection : http://i42.servimg.com/u/f42/11/72/78/09/img_1421.jpg


Once i made a mistake and connected a red wire (+) from Rx to inputs, and guess what, i had the same issue, impossible to spin motors ... i get a long beep and nothing. Only removing this red wire from Rx to inputs and everything get back OK.


Looks like you have the same effect, and it's due to multiple +V (red wires) connections on input/ouput.

Hey Dan,

So because they were new ESC's I had not actually cut 3 of the 4 red wires going to the outputs for power as commonly suggested.  I was reluctant to do it too soon as you need them when manually calibrating the ESC's.

I made up some adapter cables that I could use which has the red wire cut out.  Doing this and dialing down the rate roll P setting worked a treat and I got very stable hovering.  I then pulled the adapter wires off again and also tried booting up without powering the APM via USB first and the quad went nuts when trying to take off.

So, I put everything back how it was when it hovered perfectly but it's wobbling a little bit again (not too much but enough).  Even dialing the rate roll P down even further doesn't seem to do anything.  It still seems to wobble a little.

I'm glad I had the stable hover nailed once as I know it can do it with these new ESC's.  I just have to find the sweet spot of the config again.

I think you were definitely right about having too many red wires though.

I'm in stabilize mode and have been adjusting 'rate roll P' (locked to pitch).  This doesn't seem to make sense but this is what it suggests in the tuning wiki.  Should I be adjusting the 'stabilize roll P' values instead???

Thanks again for your help, I've made some good progress!

Good to see the progress ...

Don't cut the wires, just get them out of the connector and protect them with shrink tube to avoid any contact with something. That's the way i do. I still can get them inside connector to make calibration or else ...

And don't modify rates. First try to lower "Stabilize Roll" and Pitch linked, lowering first and only the P value.

Rates are more linked to "reaction speed". The higher rates are, the faster the quad will try to correct ...

Unless you have Stabilize values correct, do not change rates, that you will change after having a perfect stabilization.


Oh yeah good idea.  I can't believe I didn't think of that considering I've done it on some of my other connectors!

Thanks for the info on rates.  I'm packing it in for the night but will definitely try your suggestions tomorrow.

You've been a great help, I really appreciate it!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service