Hello all!

I'm currently using a 2200ma LiPo battery on board my craft. I'm getting 5 minutes of flying time. 

This is way to short for what I need it to do. I would love to get at least 15 minutes. 

Is that possible? 

Views: 3423

Reply to This

Replies to This Discussion

May I know your final result?

I'm using this motor too (NX-4006-530kv)..

@Nano -

 

With a 2kg quad, 11ah 4s battery, NX 4006 530kv motors, and APC 14x4.7 props,  I was getting a reliable 35 minutes of flight time in actual flying conditions.

 

The battery did cost $300 though.  Since I was carrying a lot of extra (non flight) batteries for the vTx and other components, you should expect similar results with less expensive (cheaper) batteries.

Arashi,

Thanks for the reply. Can I know your PID setting?

Currently I'm facing wobble problem. Please see here

Appreciate if you can help me to solve this problem..

Lower KV motors, bigger props, and the ESC's to drive them.

@Nano

I used the default PID's and it flew fine.

Correct me if I'm wrong, but it appears that your quad changes altitude a little and wobbles once when you yaw it. 

Have you calibrated the throttle on all of the ESC's?

When you yaw, two motors speed up and two motors slow down.  The wobble just after the yaw looks like two of the motors diagonally across from each other are not reacting to the throttle input equally.  The controller must sense the arm dip caused by the unequal response, then compensate for it.  This delay may be causing quick wobble.

Additionally, are all of the ESC's set on the same timing, etc.?

Arashi,

Yes it wobble and altitude change when input the yaw.

I'm using Multistar ESC. It high rate (480hz) and it auto. Mean I cannot calibrate like normal ESC. Initially I think it cause by ESC also. But I can't calibrate it. Maybe change ESc is one of solution. What type of ESC you are using?

May I know which firmware you are using? 2.9.1??

It is hard to troubleshoot without being able to calibrate the throttle.  I looked up your ESCs and it seems as though the throttle is "auto" calibrated somehow.

If you are trying to get smooth yaw for video work, I would suggest trying another set up ESCs that can be calibrated.  Or if the firmware is available, re flashing these with something that can be calibrated.

I use a variety of ESC, but mainly early Turnigy plush flashed with SimonK firmware.

http://www.rcgroups.com/forums/showthread.php?t=1513678

Depending upon which model Multistar ESC you have, they may be flashable.

There are a variety of vendors now that will sell you ESCs that are preflashed with the opensource firmware.  I have used these ones without issue:

http://www.flytron.com/multicopter-parts/181-fl30a-fast-pwm-esc.html

Most of my extensive Arducopter flying was done with the last version of the code that still supported the 1280 chip memory constraints.

Arashi, now I plan to flash my ESC with simon K. I will make it by this week end. I think this is one of the solution I can try.

Here the video how they make it Multistar SimonK

Anyway, can you let me know which APM firmware you are using? Is it the latest one (2.9.1)??

Hello Arashi,

I have a 2.2Kg quad (with 4S 10,000) running the NX-4006 motors on Graupner 14x8 props, and despite all ESCs are properly calibrated, i find that the quad feels very low on power - i have to set the throttle mid point in APM (it ranges 300-700) to full 700 to maintain a steady hover at half stick! i seriously doubt my motors are putting 1+Kg thrust each!

any tips where to look? how did yours feel compared to mine?

thanks.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service