Dear all,

I am new to the ArduPilot community and would like to start using your software and hardware on my plane. I just got a PixHawk autopilot from the 3DRobotics store and it looks like a nice piece of hardware and I can't wait to get my hands on it.

I have already installed the APM Planner2 on Windows to start getting acquainted with it but I'm also trying to install the developers code to get a better insight. I have been trying to build the code on Windows and Linux with no luck and I hope you can help me:

- Windows
I have need following the instructions listed here but I got stock on step 5. Because I can not access my username directory from the PX4 Console. Every time I try it says that the directory does not exist. I try accessing it using the Command Window and it worked. It seems like the PX4 Console cannot recognize this directory c/users/

- Ubuntu inside Windows with Virtual Box
I made it all through the end but I got a lot of compiling errors and when I try to run it again it says "Cannot find Arduino on this system, please specify on the command line with ARDUINO=

I hope somebody can help me with this.


Views: 3567

Reply to This

Replies to This Discussion

That’s for code developers that want to modify and write code. If you don’t want to write your own code but just want to fly then download the latest version of the Mission Planner and use that to install the firmware.




Dear Mike,

Thank you for your reply! Actually that is what I would like to be able to do in the not-so-distant future. We are working on a university project and would like to test our code in it so we would like to start getting acquainted with it.

Can you or anyone else help me getting started as a developer?



if you get any information can you post it here?  I too am wanting to do this.



So I am having a similar issue I think.  I have a Windows 8 PC, wanting to modify software for Pixhawk.

I have carefully followed the instructions at:

Everything seems set up as required, but I get a compile error message:

c/Users/Mike/Documents/GitHub/ardupilot/Arducopter/~.pde: No such file or directory.

I have run console in admin mode, same issue.  And same in Eclipse - but then again this uses the same console I think.

Dead in the water right now, so if anyone can help please!



My Eclipse can find the directory,but when I build the source code I get this

c:/Users/ByYoung/Documents/GitHub/ardupilot/libraries/AP_InertialNav/AP_InertialNav.cpp:8:54: error: 'const AP_Param::GroupInfo AP_InertialNav::var_info []' is not a static member of 'class AP_InertialNav'

make[3]: *** [libraries/AP_InertialNav/AP_InertialNav.cpp.o] Error 1
make[1]: Leaving directory `/c/Users/ByYoung/Documents/GitHub/ardupilot'
make[2]: *** [/c/Users/ByYoung/Documents/GitHub/PX4Firmware/Build/] Error 2
make[1]: *** [/c/Users/ByYoung/Documents/GitHub/PX4Firmware/Build/] Error 2
make: *** [px4-v2] Error 2

and no .px4 file created.

Hi there,

I get error 2 and 5 as well.

Any guess?

I found this link and it worked actually, for those who need help:!topic/drones-discuss/PeL1KYYoEH0



Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service