Installing Mission Planner on Windows 8 (Fails then) Succeeds

I am running Windows 8 Preview 64 Bit in Virtual Box on OSX Lion on an old MacBook Pro.

I did enable .Net 3.5, which is required by Mission Planner. When running the APM Mission Planner installer, it announces that an error has occurred and aborts the installation.

I realize that there could be all kinds of issues leading to this, and the Error is completely generic. But maybe someone here has come across this situation and solved it ?

Thank You,


Views: 1225

Reply to This

Replies to This Discussion

Wow, you are pushing the limits... A beta MS O/S in a sandbox on older Apple hardware.
The odds of others having a solution to this combo must be kinda high.
Wish I could help.

I don't think it is reasonable to ask the community or Michael Oborne to support MP on an unreleased, beta preview OS, do you? 

Rather, if you have the background for it, you might offer to Michael Oborne your time and system to beta test and test MP on Win8. 

I mainly run MP on Win7 within Parallels on OSX Lion, I am sympathetic....but really? Just my opinion....offer to help as a test platform. Expect it to not work. 

Mike, you are absolutely right. I want by no means make any demands that this platform be supported.

Just wondering if anyone has come across the situation.

If it did work, it would be a neat option for non-windows owners, since both Virtual Box (runs on Linux too) and the Windows 8 Preview are free.

my guess it will be failing at the driver install, try the zip file version.

I'm going to bet that the Win8 preview license has some encumbrances that Microsoft expects are followed, and some of them surely preclude the day to day use of Win8 Preview for our purposes. I haven't read the TOS/license, and I'm no lawyer, but I would be cautious about promoting its use outside of those terms lest you attract the attention of the wrong people..

In any case, I'm sure the terms allow for application testing, and any data you can collect might be helpful in preparing for the full Win8 release. I recommend some of the sysinternals tools to collect information about open files, process tracing if it crashes, and Michael might have some debug versions and a better recommendation for what (and how) he'd like it tested.

Well, I could not find any license restrictions in the consumer win8 preview... I guess the approach they are using is to expire the OS after a specific date. You can see the date your install will expire if you issue the command "winver" in a command line or in Start->Run. 

Any testing we can get done before that time would be helpful, I'd think...unusually nice of Redmond

I tried the Zip file version, as Michael suggested, and it works.

Getting the 3DR Radio to work took some tweaking, but nothing too complicated:

1. I downloaded the FTDI device driver on win8, linked from the wiki, using the self-running installer, doing a legacy install after the initial install.

2. I installed the Virtual Box Extpack which offers USB 2 support (not sure if that was even needed)

3. I set up a USB filter for the radio (FTDI device) in the VM's settings.

4. Set the COM port in APM to 3 (found the FTDI device there in win8 device manager)

So, keeping in mind that this takes a little elbow grease, that this is not an official platform, and also that the preview will expire, I think this is still a lot better then not running APM Planner. I still have my main desktop PC with the planner running on an older windows version, but with this laptop, I can now do productive tuning in the field.

Thank you for your help ! Good luck with your own installs.

Thanks for working through the issues and communicating your findings here. 

Great experimenting! Thats the spirit of this community... Pushing the envelope.
I was skeptical being that the Win8 GUI is so new and different, and the driverissues, esp given the cross platform hardware.
Good post.

Maybe issues with 32-64bit application calls for that driver. dism on .net3.5 was acting up on me as it kept using the 32bit version for example.

FYI, having the same problem on Linux with VB (both 64 bit) :) BUT zip version works.


I am running Win8 Pro 64bit on my laptop and finally installed the Arduino 2560 INF(,94651.msg716650.html#msg716650) for APM2 and now the device manager recognizes the APM board when I connect it. But, I am unable to run APMplanner.exe for the zipped version(Missionplanner unlike what seems to be reported here. The CMD gets stuck at 

"--End of inner exception stack trace--

at ArdupilotMega.MainV2..ctor<>

at ArdupilotMega.Program.Main<> in C:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Program.cs:Line 70"

I don't know if the above information was any helpful, but could someone tell me what I am doing wrong.

To my good luck, the older version (Mission Planner 1.1.92) works like a charm. Maybe some changes done in the later versions have created the difficulty.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service