I have a question about two fields in the on-board log files :  

1) How do you interrupt the time in the GPS field.  It doesn't seem to be NMEA or time-since-epoch.

2) Is there an enumeration of the I2CErr values in the PM log record?


Views: 255

Reply to This

Replies to This Discussion

And one more question - when is a new log file created?  It seems like I get a lot of them - maybe a new one or two every minute.  Some of them have no data logged, just the header and field descriptions.


    dataflash logs are created in arduplane whenever you plug it in.

    the gps time field is in milliseconds since epoch

    the i2c errors are not enumerated but each PM message will tell you the number of errors since the last PM message

Thank you so much for your help.  This is driving me crazy.

So if I had multiple log files created - say 1 or 2 a minute while the FC was powered up, that would be a Bad Thing?

And if I had random values (positive and negative) for the i2c error values, that might indicate that I'm getting a LOT of them and I'm getting overflow in the counts?

The initial problem I'm trying to track down is that the flight mode seems to randomly change on its own and often doesn't respond to my RC commands to change.  That, and at random, usually very inopportune times my throttle goes to zero.  Oh yeah, and the 3DR radio locks up.  These problems are repeatable without a motor connected to the ESC, while stationary on my workbench.

I'm really starting to suspect a hardware problem. This is one of the first APM2s from last year - I was on the pre-buy waiting list.


    Ok, sounds like trouble.  multiple log files created every few minutes sounds like the apm is restarting but maybe it's something else.  I almost never seen any i2c errors in logs i look at so that also sounds very bad.

    you've of course done the old "cli, setup, reset, Y" thing to reset all params to defaults?

Yep, I did the reset quite a few times.

I also swapped a different APM board into this build and I'm not seeing any problems.

This board may have a history.  When I first got it last year and tried to install the firmware and it froze up on me.  I sent it back to 3DR and eventually got back what I thought was a new board.  Maybe it was this one with more problems that weren't fixed.  I got impatient waiting for the replacement/repair and bought a 2nd board which I've been using successfully on a tricopter.  And I bought a 2.6 board which I have in a quad.  So it wasn't until just the last couple weeks that I've gotten around to work with this original board.  Which is now kind of appearing like it's never worked right.

I'm guessing 14 months is beyond any warranty period...

Thanks again for the help!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service