Hi,

I bought an IRIS+  in 2015 with a Tarus camera gimbal and flew it a few times-- including some auto Missions.  Then I discovered 3DR had gone out of business and the copter has largely sat on the shelf for 7 years.  I just bought 3 new batteries for the copter and one for the radio  and the copter flew fine for 5-6 times--including 1-2Missions loaded on from Mission Planner.  

--Then I began getting the blinking yellow light instead of the blue green light sequence indicating successful pre-arming checks and GPS lock.  Also, every time I hooked the copter to Mission Planner (Ardupilot), I got a message about updating the firmware on the Pixhawk-- so I followed the instructions on the arducopter website and installed new firmware.  The instructions said the parameters would remain unchanged, but after the upgrade, it has been nothing but trouble-- one arming message after another: "needs accelerometer calibaration", "Arming light problems" etc.  Also, the safety button/arming light acts very bizarre, and other things.  For example: LED on copter after plugging in battery turns blue (after red/blue flashing pre-arm checks), I get a solid blue light and a message about the arming button,-- I push the arming button and it goes from flashing red to solid, and the other led goes from blue to flashing green, then solid green (supposed to mean GPS FIX), but down/right on the radio does not start the props.  Also, camera gimbal no longer responsive to radio controller.  

--Sorry about the long rant-- but it's a mess.

I tried loading the stock prams back on the copter from the drop-down menu in Mission Planner, but that didn't help.

---Bottom line: I am grounded and don't know how to proceed:  --how can I just get this copter back to the original configuration-- which worked?

--Obviously I'm no expert at this, but I can follow instructions.

Thanks in advance,

Bob

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

                    • Hi Bob - OK, you need to set up battery monitoring. MP -> SETUP -> OPTIONAL HARDWARE -> BATTERY MONITOR. ( The SIK telemetry radio link is in OPTIONAL as well - I previously sent the ardupilot link...)
                      John
                    • Bob, got your .bin....my bad, disregard the latter part of my previous!
                    • Hi Bob - Not professionally! But I'm a technology freak and can't believe how much the RC world has advanced in the few yrs. I've been out of it...candy factory. Anyway, I think I know where the tilt parameter is lurking; let me check before opening my mouth. As far as telemetry goes, I'm assuming you're using the IRIS controller - yes, I see you are. What you'll need to do is sync the 3DR (SIK) data radios. The only thing to check after the sync is to insure the 'net ID' is identical on both radios. Right now, don't change anything else in there.
                      https://ardupilot.org/copter/docs/common-configuring-a-telemetry-ra...
                      I'm checking the CH 6 stuff now...
                      ---- What I need is the .bin file from the PX4. In MP, with the drone connected, scroll over to 'Dataflash Logs', select 'Load log by Mavlink', then pick the flight log from the popup. Then, say 'Review a Log' and it'll take you to the MP folder, select Logs -> Quad-> 1. In the resulting files, there will be a .bin file. That's what I need! Later, John!
                      Configuring a Telemetry Radio using Mission Planner — Copter documentation
                    • Hi John, I've gotten the log bin files off the iris and finally found them on the PC.
                      --what follows might be a link to a dropbox folder with three sets of logs-- lots of files you would understand but are definately Greek to me.

                      https://www.dropbox.com/scl/fo/u6uuwlhu4xy6fhdeqo9pa/h?dl=0&rlk...

                      -if this doesn't work I don't know how to get the logs to you-- as you noted, there is no option for adding a file in the "messages" or at lease I don't know how to do it!
                      --Yes, I am getting somewhere with this drone--it now passes all the pre-arming checks (I had to calibrate just about everything to get this to happen). Only a few problems remain: one is this camera "Tilt" knob on my FS_TH9X Controller that came with the iris. Using Mission Planner, I was able to re-program the "Flight Modes" switches and the joysticks. Yes, I'm pretty sure I read that channel 6 on the controller is used for the gimbal "tilt", but I can't figure out how to do this in MP.
                      Also, while I have full control of the drone with the controller, I have no data feedback from the drone to the small screen on the controller-- it used to give me battery voltage, # of sattelites and other things--now nothing.
                      Thanks for all your help. I read your profile and apparently you do this professioally--is that right?
                      Best,
                      Bob
                      1
                      Shared with Dropbox
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…