Iris+ reduced throttle and crashed despite my full throttle command - no failsafe triggered

The subject says it all.  I was camping with my Iris, and my first flight was doing well, I started climbing to get a higher perspective and noticed the copter drifting so I switched to loiter.  Right when I hit the switch it lost a ton of altitude so I switched back to althold and tried cycling the throttle back to hover but it didn't seem to help so I went back to 100% and tried to bring it home.  It started climbing then just descended on its own into the rocks and crashed.  The descent looked somewhat controlled, like if I have it at min throttle or when it is in the first part of land mode.  The logs show no failsafes triggered but it appears the pixhawk ignored my full throttle command and sent min throttle to all the motors anyways.  The baro and gps alt graphs follow the path I remember, so I don't think that was the issue.  I have 3.2.1 with a second GPS and a tarot gimbal with a 3D printed mobius adapter.  I don't want to just send this thing skyward again until I know what happened.

Thanks.8%206-26-2016%208-27-12%20AM.bin

Views: 114

Reply to This

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service