Hi Guys,

I was trying to setup a Logitech Attack3 joystick for manual control of my APM running the latest ArduPlane 2.4 firmware.

I'd like to mention that I have NO R/C system connected to the APM (I don't even own one). Perhaps this is the problem. If it is so, I think you guys might be able to provide me with a solution with the below problem.

I opened Mission Planner after attaching the joystick and opened the joystick panel. After setting it up, all the axes worked perfectly. I had previously calibrated the joystick in Windows.

But, when I connect to the APM via through Xbee @ 57600 baud, the joystick control stops working. The values in the panel revert and freeze. No joystick inputs are taken. APM status tab shows all the R/C override channels to be permanently set at 1500 PWM. Tried via USB and same problem.

One important thing here, the buttons keep working even after connecting, probebly because they are not overriding the R/C channels.

I have to close and reopen Mission Planner to get joystick functions back, but only till the APM is not connected.

Please HELP!!


Views: 8145

Reply to This

Replies to This Discussion

Hey Dan,

Do Michael's modifications in the latest ArduPlane code (2.68) and it works fine. Redo the radio calibration after this. Should work fine for you.


Oh sorry! Forgot to mention I am running ArduCopter 2.7.3.

Do you think this is the issue?

The fix should be the same. Just take off your props when testing for the first time.

Dan: Please run the latest code. The current ArduCopter is 2.8.1 and is much improved.  

I think probably even the latest AC code won't fix the joystick problem. But modifying the latest codebase will have its advantages.

hello! Am having a weird problem, i have connected a logitech attack 3 joystick to my system, i intend to only use the joystick system and eliminate the radio for the time (testing), i have assigned the axes to the required channels also, problem is :

if i pull my joystick (elevator : X axis), I get a pitch up in the plane

but when i push my joystick down (elevator : X axis), I do not get any pitch down, nothing happens!!

infact the green bar on the Joystick menu does not move to register the 'Down' Movement!!

I need help! iam not a programmer so ill be very grateful if somebody could explain the solution to me.



Hmm, it seems that your joystick is not calibrated properly in Windows. Redo "Set up USB game controllers" in Windows and then redo your Radio Calibration in Mission Planner.

That should fix it :)

I caliberated it in windows, rechecked it twice!!


Then redo your Mission Planner radio calibration.

somehow after repeated attempts of calibration and succesfully completing them failed to resolve the issue! iam using win 7, i tried doin the exact process in win xp. 


Have you done RADIO CALIBRATION in Mission Planner (not windows joystick calibration) Also you might want to install Logitech Profiler, which might help. 

Another thing to try is trying it on a different OS. Windows XP is sooooo old.

i did the caliberation in Mission Planner too, several times, and evry time the X axis : Elevator channel range is only being :1388 and lower side 1322, also when i push the stick down during calibration the green bar wudnt move!!

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service